Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just purchased a new laptop and started by installing Xubuntu onto it.

I can't seem to get any controls to work for my video card. Being fairly new to Linux, I'm not sure what steps to take to debug this, nor what steps to take to repair it.

Here are some of the problems I'm having:

  • Backlight Keys nonfunctioning
  • Cant change backlight with xbacklight 'No outputs have backlight property'
  • In Display in Settings, I can't change Resolution, or anything else
  • In Display in Settings, I only have default listed

nvidia_current is installed and sudo lshw -C display shows the following output:

*-display               
   description: 3D controller
   product: GK106M [GeForce GTX 765M]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list rom
   configuration: driver=nvidia latency=0
   resources: irq:16 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
*-display UNCLAIMED
   description: VGA compatible controller
   product: 4th Gen Core Processor Integrated Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 06
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller cap_list
   configuration: latency=0
   resources: memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)

I'm desperate for help as at the moment, I'm finding my screen far to bright to work on, and I'm starting to lose the will to live.

Update

I've just discovered that Xorg appears to be disabling my nvidia drivers:

ubuntu-drivers debug

DEBUG:root:X.org log reports loaded intel driver, disabling driver nvidia-173 for hybrid system
DEBUG:root:X.org log reports loaded intel driver, disabling driver nvidia-304 for hybrid system
DEBUG:root:X.org log reports loaded intel driver, disabling driver nvidia-304-updates for hybrid system
DEBUG:root:X.org log reports loaded intel driver, disabling driver nvidia-319 for hybrid system
DEBUG:root:X.org log reports loaded intel driver, disabling driver nvidia-319-updates for hybrid system

How do I solve this issue?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.