Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on Natty 11.04.

I have been noticing that upon wake-up from a long inactivity, the screen is not responding to any keystrokes. The mouse is moving though.

This is happening when I am on AC power. The power settings for on AC power are :

  • Put computer to sleep ... = Never
  • When laptop lid is closed = Suspend (The issue happened when laptop is open and screensaver is ON)
  • Put display to sleep when inactive for = 0:15
  • Display brightness is 100% and Dim display option is not selected.

Not sure why this is happening. Need your help please to understand the problem and correct it.

share|improve this question
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  fossfreedom May 16 '12 at 19:32
add comment

closed as off topic by fossfreedom May 16 '12 at 19:32

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

up vote 1 down vote accepted

This issue is being tracked on Bug #762918, there seems to be some tricks that reduce the probability of getting screen freezes:

  1. Install kernel 2.6.39 or superior
  2. Disable sync to v_blank using compizconfig-setting-managerinstall ccsm (its on General -> OpenGL)
  3. Add pcie_aspm=force to the boot options. This should also lower power usage.
    • gksudo gedit /etc/default/grub
    • Add pcie_aspm=force in GRUB_CMDLINE_LINUX_DEFAULT
    • Run sudo update-grub and reboot.
share|improve this answer
    
Sorry for my delayed response. Thanks for your suggestion. I am yet to reproduce this issue in 11.10 as yet. So I think this issue is solved for me. –  Arindom Oct 26 '11 at 4:26
add comment

This might be a duplicate of Segio's answer, but I find the discussion more relevant: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/781402

I disabled sync to v_blank and it seems to have fixed it for me.

I would have posted this in a comment, but I don't have enough rep yet.

share|improve this answer
add comment

U can try this one: http://www.multimediaboom.com/fix-screensaver-freezes-in-ubuntu-11-04

share|improve this answer
    
Many thanks for the link. –  Arindom Oct 26 '11 at 4:28
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.