Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have trialed to use Network, NAP profiles on Bluetooth.

On Host, xUbuntu 13.04 I have followed as here.

This Host or XUbuntu machine is behind proxy & runs on virtual machine.

It is installed with Bluetooth version 4.101

On embedded board, ping 173.194.112.211 responds as below:

PING 173.194.112.211 (173.194.112.211) 56(84) bytes of data.  
64 bytes from 173.194.112.211: icmp_req=1 ttl=46 time=336 ms  

On embedded board, ifconfig shows as below:

bnep0     Link encap:Ethernet  HWaddr 3E:DA:FB:6C:EE:BC  
          inet addr:10.220.129.178  Bcast:10.255.255.255  Mask:255.0.0.0  
          inet6 addr: fe80::3cda:fbff:fe6c:eebc/64 Scope:Link  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1  
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0  
          TX packets:458 errors:0 dropped:0 overruns:0 carrier:0  
          collisions:0 txqueuelen:500  
          RX bytes:1793 (1.7 KiB)  TX bytes:36870 (36.0 KiB)  

eth0      Link encap:Ethernet  HWaddr 0C:23:C0:80:C0:E8  
          inet addr:10.122.83.127  Bcast:10.255.255.255  Mask:255.0.0.0  
          inet6 addr: fe80::e23:c0ff:fe80:c0e8/64 Scope:Link  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1  
          RX packets:24555 errors:0 dropped:611 overruns:0 frame:0  
          TX packets:20647 errors:0 dropped:0 overruns:0 carrier:0  
          collisions:0 txqueuelen:1000  
          RX bytes:3374125 (3.2 MiB)  TX bytes:5878612 (5.6 MiB)  

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0  
          inet6 addr: ::1/128 Scope:Host  
          UP LOOPBACK RUNNING  MTU:65536  Metric:1  
          RX packets:25809 errors:0 dropped:0 overruns:0 frame:0  
          TX packets:25809 errors:0 dropped:0 overruns:0 carrier:0  
          collisions:0 txqueuelen:0   
          RX bytes:3824780 (3.6 MiB)  TX bytes:3824780 (3.6 MiB)  

polo0     Link encap:Ethernet  HWaddr 02:00:00:00:00:01  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0  
          inet6 addr: fe80::ff:fe00:1/64 Scope:Link  
          UP BROADCAST RUNNING MULTICAST  MTU:65536  Metric:1  
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0  
          TX packets:696 errors:0 dropped:0 overruns:0 carrier:0  
          collisions:0 txqueuelen:1000  
          RX bytes:0 (0.0 B)  TX bytes:117357 (114.6 KiB)  

On embedded board, I issue command: ping -I bnep0 173.194.112.211
This is google IP address by the way :)

After long time, I press Ctrl + c, it gives this:

PING 173.194.112.211 (173.194.112.211): 56 data bytes
^C
--- 173.194.112.211 ping statistics ---
541 packets transmitted, 0 packets received, 100% packet loss

On embedded board, I also trialed changing bnep0 inet addr to: 10.122.83.128.
For sure no one has this IP address.

It did not work...

hcidump -X shows these packets when I ping, not other times.

HCI sniffer - Bluetooth packet analyzer ver 2.4
device: hci0 snap_len: 1028 filter: 0xffffffff
> ACL data: handle 38 flags 0x02 dlen 47
    L2CAP(d): cid 0x0042 len 43 [psm 0]
      0000: 00 ff ff ff ff ff ff 3e  da fb 6c ee bc 08 06 00  .......>..l.....
      0010: 01 08 00 06 04 00 01 3e  da fb 6c ee bc 0a dc 81  .......>..l.....
      0020: b2 00 00 00 00 00 00 ad  c2 70 d3                 .........p.
> ACL data: handle 38 flags 0x02 dlen 47
    L2CAP(d): cid 0x0042 len 43 [psm 0]
      0000: 00 ff ff ff ff ff ff 3e  da fb 6c ee bc 08 06 00  .......>..l.....
      0010: 01 08 00 06 04 00 01 3e  da fb 6c ee bc 0a dc 81  .......>..l.....
      0020: b2 00 00 00 00 00 00 ad  c2 70 d3                 .........p.
> ACL data: handle 38 flags 0x02 dlen 47
    L2CAP(d): cid 0x0042 len 43 [psm 0]
      0000: 00 ff ff ff ff ff ff 3e  da fb 6c ee bc 08 06 00  .......>..l.....
      0010: 01 08 00 06 04 00 01 3e  da fb 6c ee bc 0a dc 81  .......>..l.....
      0020: b2 00 00 00 00 00 00 ad  c2 70 d3                 .........p.

I wish to access internet On embedded board, over Bluetooth, via xUbuntu's Ethernet's internet connection, NOT Ethernet of embedded board.

Someone please help me to get this working.

share|improve this question
1  
check route on pc with command route. Maybe ping to 173.194.112.211 go to some different interface and when you add interface to ping command packet can't go back to remote host or back. –  2707974 Apr 2 at 7:33
    
Appreciating your guidance, I have posted route output in the query above, what next? –  AjayKumarBasuthkar Apr 2 at 8:00
    
Your default route is on eth0 interface. Try to add route add -host 173.194.112.211 gw ip_address_wich_is_gw_for_bnep0 –  2707974 Apr 2 at 8:10
    
route now shows new record: 173.194.112.211 10.0.2.2 255.255.255.255 UGH 0 0 0 eth0. Yet no luck, ping says not reachable... –  AjayKumarBasuthkar Apr 2 at 8:16
    
You have the same gw for bnep0 and eth0? –  2707974 Apr 2 at 8:18

1 Answer 1

up vote 0 down vote accepted

I configured bnep0 network interface on xUbuntu 13.04 with local IP address and it workded :)

# ifconfig bnep0 192.168.1.3 up

I also guess that command route also helped.

The ping works, however, there is packet loss...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.