Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

when I closed the empathy messenger client, a little icon used to show up as a notification. When I got incoming chats, the icon used to start flashing. I reorganized content on my panel and now that functionality is gone! I tried adding "Indicator-Applet" to the panel but all this does is show up an envelope which lights up when there is some activity on empathy. I want to use the Empathy voice bubble icon instead. Any tips appreciated.

I am using Ubuntu Lucid Lynx 10.0.4.

share|improve this question
remove that envelope if you want with sudo apt-get remove indicator-messages... – sagarchalise Sep 20 '10 at 11:59
indicator-messages package doesnot remove the applet as a whole but just the envelope icon. The bubble icon of empathy would appear as default icon if you remove it. I didnot mean to remove indicator-applet but just messages so that the envelope would not appear – sagarchalise Sep 23 '10 at 11:31
up vote 5 down vote accepted

Solved. These are the steps I followed:

  1. Quit Empathy if it is running.
  2. Launch Empathy. Then, Edit -> Preferences -> Notifications. Uncheck the "Show incoming messages in the messaging menu" box. This will put up the Empathy bubble notification icon in the panel.

The process will work irrespective of whether you have the Indicator-Applet added to your panel or not.

share|improve this answer

I wouldn't remove the indicator-applet, as it also is your sound menu and power indicator.

Check this bug out on Launchpad. Is it the same as you're reporting? If it is, please sign in and click the link where it says "This bug affects X people. Does it affect you?". There are also some things to fix this issue in the bug thread.

I haven't found a plugin for empathy to add the tray icon back.

share|improve this answer
No, it isnt the same problem. However, I could find a solution to my problem by looking at the comments in the bug thread, so thanks! I have added the solution as a separate answer. – suhridk Sep 23 '10 at 10:50
Glad you found what you needed. – gamerchick02 Sep 23 '10 at 14:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.