Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

**

QUESTION

**

My laptop model is ASUS F550CC with NVIDIA 720M (not optimus) graphics card.

I'm confused with what method should I really use to install NVIDIA 720M in my Ubuntu. Should it be via PPA, Additional Drivers or NVIDIA's website?

What I did was to install the two NVIDIA drivers that appeared in the Additional Drivers upon fresh Ubuntu installation. With the image file attached, it can be seen that Ubuntu cannot detect my graphics card.

I also installed mesa-utils to run glxinfo but I got error messages as depicted in the image file attached below.

When I run lspci | grep NVIDIA, it showed my driver. I'm really confused. One says it cannot be detected, another said it can. What should I believe in? Also how do I really test if NVIDIA is correctly installed (e.g. running some sort of test program)? Also did I installed it correctly?

Here is the detail on how I installed my Ubuntu upto NVIDIA:

  1. Installed Ubuntu 12.04 x64 without installing updates upon fresh installation. (For faster Installation)
  2. Installed one of the proprietary drivers and restart.
  3. Installed the other one and restart.
  4. Installed mesa-utils.

Final Update:

enter image description here

Troubleshooting process: check the comments also

Running sudo nvidia-settings shows the NVIDIA GUI

I also run sudo nvidia-xconfig and sudo reboot

Now I got this ugly video resolution. I also run glxinfo again but got the same error message but the details does not display unknown anymore but none at all.

enter image description here

Here is the /etc/X11/xorg.conf after I executed sudo reboot..

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 331.20  (buildmeister@swio-display-x86-rhel47-05)  Wed Oct 30 18:20:53 PDT 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Running dmesg | grep NVIDIA gives enter image description here

Nvidia-settings configuration window enter image description here

share|improve this question
    
what about when you do --- sudo nvidia-settings --- do you get the GUI –  Tasos Apr 1 at 2:35
1  
Did you run sudo nvidia-xconfig? –  Danatela Apr 1 at 2:38
    
@Tasos Edited the post. Yes I get the GUI. I also attached the image file for it. –  Xegara Apr 1 at 2:45
    
@Danatela Not yet. Should I? –  Xegara Apr 1 at 2:46
1  
Yes. It should activate the installed driver. –  Danatela Apr 1 at 2:49

2 Answers 2

You should run:

sudo nvidia-xconfig
sudo modprobe nvidia
sudo restart lightdm

This will activate the installed driver.

Actually, xorg.conf is anachronism. Newest X drivers do not need it. But NVIDIA wants it to be written to work properly. Example /etc/X11/xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.108  (buildmeister@swio-display-x64-rhel04-06)  Wed Jul 31 20:47:43 PDT 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this answer
    
I've updated my post. The resolution is now ugly. –  Xegara Apr 1 at 3:08
    
Now run sudo modprobe nvidia. –  Danatela Apr 1 at 3:10
    
I ran it. Nothing happened. Should I reboot? –  Xegara Apr 1 at 3:11
    
just restart lightdm –  Danatela Apr 1 at 3:12
    
I just did too but the resolution is still the same. I also posted the xorg.conf above. –  Xegara Apr 1 at 3:12
up vote 0 down vote accepted

SOLVED!

Installing NVIDIA 720M card (Non-optimus)

1. Install proprietary drivers with restarting after each driver's installation.
2. run the following:
sudo apt-get install mesa-utils
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get dist-upgrade
3. Install again proprietary driver and restart.
4. Press start and click Details. You will see the graphics card installed.
(We do not need to run sudo nvidia-xconfig)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.