Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am currently running Xubuntu 12.04. I dislike the menu and window drop shadows, therefore I went to Window Manager Tweaks, then navigated to the Compositor tab. Inside the compositor tab, I unchecked the areas that said "Show shadows under regular windows" and "Show shadows under popup windows." This worked for a few minutes, then the shadows reappeared. Is there another place I have to disable the shadows?

Any help is appreciated, Thank you :)

share|improve this question

WM Tweaks > Compositor is indeed the correct place for disabling such effects. Try disabling compositing altogether in that window, to see if the undesired effects stop. And if they do, then reenable compositing and try to disable sequentially each of the options in that dialogue until you find the one that is offending. The disable that.

If nothing works, please provide a screenshot of the WM Tweaks > Compositor and of the issue that you're seeing.

Alternatively you can use xfwm4-composite-editor that you can install from ppa:rebuntu16/other-stuff. It allows you to tweak more finely the compositor settings, as described here. Once installed, access it from Settings > Other.

share|improve this answer
Unfortunately this did not work. Disabling the compositor does indeed eliminate the effect. However disabling the options sequentially did not remedy this. – user263163 Apr 1 '14 at 4:54
That is strange. Please provide some screenshots of the issue. – landroni Apr 1 '14 at 5:12
LINK and checking or unchecking any of those options does not change anything anymore. Maybe my compositor is messed up or out of date since this is a fresh install of Xubuntu 12.04. Thanks for your help, by the way – user263163 Apr 1 '14 at 5:49
What about a screenshot when compositing is disabled (preferably after a full reboot)? – landroni Apr 1 '14 at 5:58
link This removes the shadows, but I do not believe the 3d graphics in video games would run well like this, plus I would also like to keep the opacity of my panels. – user263163 Apr 1 '14 at 6:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.