Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok so I spent all day yesterday trying to get my wireless adapter to work with Ubuntu 13.10. I have internet access on my Windows install, but it's not working on Ubuntu. Downloaded and installed ndiswrapper and utils, downloaded bcmwlhigh6, as it corresponds to my wireless device (Netgear WNDA3100v2, BROADCOM4323, ID 0846:9011). Running ndiswrapper -l shows the driver as installed and the device ID is showing up as well. But I still have no wireless! Please help! This is really only my second day using Linux. I'm completely at a loss. UPDATE: Ok, I have gotten ndiswrapper to install correctly, so I'm no longer getting a fatal error when I run a modprobe. However, I don't get anything back from that, it just goes to a new line in the terminal. Going to try what was suggested and install ndiswrapper-dkms (just tried this, however, I'm going to have to install the package dkms before I can install the one for ndiswrapper), and I'll see if I can get either bcmwlhigh5 or bcmwlhigh6 to work. Will post back when I have done this. UPDATE 04/03: Alright guys, thanks for all your help. I've gotten the wireless card up and running, and for those of you struggling with this particular wireless adapter, here's how: Downloaded and installed the latest version of ndiswrapper. Downloaded and installed ndiswrapper-source, ndiswrapper-common, ndiswrapper-utils, and ndiswrapper-dkms (requires package dkms prior to installation). The driver I found to actually work was neither bcmwlhigh5 nor bcmwlhigh6. It was actually an open-source driver called bcmn43xx64 (or bcmn43xx32, if you're running a 32-bit OS). Downloaded this and installed via ndiswrapper. Once the driver was installed, I ran sudo ndiswrapper -m, followed by sudo modprobe ndiswrapper. I honestly wasn't expecting much, but when I ran iwconfig it came back showing my wireless adapter! Thanks everyone for your help! And if you have trouble with this adapter, I hope you found this informative and useful!

share|improve this question
    
I doubt that bcmwlhigh6 is correct. You might try the files at post#6 here: ubuntuforums.org/showthread.php?t=1964173 –  chili555 Apr 1 at 12:54
    
@searchfgold6789 His device can only work with ndiswrapper and is not covered at the link you gave. I don't believe it's a duplicate. –  chili555 Apr 1 at 15:39
    
Ok, so I think I may have found the problem, but I still can't figure out how to fix it. ndiswrapper is showing the driver and the device, BUT running a modprobe ndiswrapper command brings back a fatal error saying there is no ndiswrapper module. Running the command ndiswrapper -v says the same thing. I have the source, common, and utils files depackaged but apparently I'm missing something. –  Lojik Apr 2 at 15:03
    
Also try installing ndiswrapper-dkms and try again. –  chili555 Apr 2 at 20:14
    
@chili555 Reopened. –  Seth Apr 2 at 20:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.