Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I recently installed Ubuntu 13.10 (later upgraded to 14.04 in an unsuccessful attempt to fix the problem) and have been having trouble with the wired Internet. Specifically, the Internet connection is dropping intermittently, maybe for 15-90 seconds every minute or two.

Curiously, I never have any problems pinging another computer plugged into the same switch. Only the external Internet drops. However, I don't have any issues with the external Internet when I plug my MacBook into the same Ethernet switch.

It's not a DNS issue, as the issue persists if I try to ping Google by IP address instead of using

I actually have two network cards in the machine (each with two Ethernet ports). The cards use different drivers, namely e1000e and ixgbe. I encounter the same problem no matter which card I plug into.

I was originally on Ubuntu 13.10 and kernel 3.11. I upgraded to Ubuntu 14.04 and kernel 3.13.0-20, but it didn't fix the problem. I also tried disabling the 3 interfaces (two ports on the other card and the unused port on the active card) and stopping network-manager, but that didn't seem to have an effect either.

There's nothing obvious in /var/logsyslog or kern.log. In particular, the times when the Internet stops and starts again don't lineup with DHCP renewals.

Any ideas? I'm stumped here, so any help would be very much appreciated.


share|improve this question

3 Answers 3

Is it a clean install of 14.04? Maybe you could try to do that. I've read that upgrading between version is not always 'safe'.

share|improve this answer
No, it was an upgrade. I'll try a fresh install, thanks! – alexrs Apr 1 '14 at 17:57
Did it work out? – user229948 Apr 3 '14 at 20:23

I tried rejigging the network interfaces. I plugged an Ethernet cable into all 4 ports, brought them all up, and re-enabled network-manager. So far, it seems to be working now.

share|improve this answer

I am using Ubuntu 14.04 (did a clean install from Ubuntu 13.10 recently) on my Desktop machine. Since an upgrade in 13.10 earlier my system has started showing strange behavior of intermittent disconnections in browsing. At that specific moment pinging proxy halts with more than 80% packet lost. Sometimes its even unreachable as shown below. At that specific moment I get reconnection if I reset LAN connection. By the way LAN connection remains connected always.

Some ping behaviors and ifconfig results are shown below.

user@user-desktop:~$ ping PING
( 56(84) bytes of data.
64 bytes from icmp_seq=13 ttl=128 time=0.283 ms
64 bytes from icmp_seq=14 ttl=128 time=0.275 ms
64 bytes from icmp_seq=15 ttl=128 time=0.303 ms
64 bytes from icmp_seq=16 ttl=128 time=0.272 ms
64 bytes from icmp_seq=17 ttl=128 time=0.302 ms
64 bytes from icmp_seq=18 ttl=128 time=0.509 ms
64 bytes from icmp_seq=19 ttl=128 time=0.570 ms
64 bytes from icmp_seq=20 ttl=128 time=0.211 ms ^?^C
--- ping statistics ---
40 packets transmitted, 8 received, 80% packet loss, time 39100ms rtt
min/avg/max/mdev = 0.211/0.340/0.570/0.120 ms

user@user-desktop:~$ ping PING
( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable From icmp_seq=2 Destination Host Unreachable From
icmp_seq=3 Destination Host Unreachable From icmp_seq=4
Destination Host Unreachable From icmp_seq=5 Destination
Host Unreachable From icmp_seq=6 Destination Host
Unreachable From icmp_seq=7 Destination Host Unreachable
From icmp_seq=8 Destination Host Unreachable From icmp_seq=9 Destination Host Unreachable From
icmp_seq=10 Destination Host Unreachable From icmp_seq=11
Destination Host Unreachable From icmp_seq=12 Destination
Host Unreachable ^C
--- ping statistics ---
13 packets transmitted, 0 received, +12 errors, 100% packet loss, time

user@user-desktop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 78:ac:c0:bb:67:d4 
          inet addr:  Bcast:
          inet6 addr: fe80::7aac:c0ff:febb:67d4/64 Scope:Link
          RX packets:240643 errors:0 dropped:0 overruns:0 frame:0
          TX packets:223734 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:25537053 (25.5 MB)  TX bytes:17135945 (17.1 MB)
          Interrupt:19 Memory:f0100000-f0120000

lo        Link encap:Local Loopback 
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:478 errors:0 dropped:0 overruns:0 frame:0
          TX packets:478 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:67030 (67.0 KB)  TX bytes:67030 (67.0 KB)
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.