Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having trouble playing DVDs. I've installed all the libraries and whatnot (ubuntu-restricted-extras, libdvdcss2, libdvdread4, etc.). I was getting a lot of I/O errors on my DVD drive at startup and when I tried to play a DVD.

But I just bought a new DVD drive and I'm having the same problem. I switched out the SATA cables and tried a couple different SATA ports on my mother board, so I'm pretty sure that's not the issue.

Basically, the situation is this. I start up and after BIOS loads, but before GRUB shows up, I get a quick error saying error: cdrom read error. Then I boot normally, and everything is seemingly great. If I put in a DVD, it mounts, but I'm not able to play it or copy the files off of it.

I did a dmesg | tail before and after putting in the DVD.


[  119.467771] wlan0: direct probe responded
[  119.515673] wlan0: authenticate with 00:23:69:5b:30:0f (try 1)
[  119.519117] wlan0: authenticated
[  119.520288] wlan0: associate with 00:23:69:5b:30:0f (try 1)
[  119.522256] wlan0: RX AssocResp from 00:23:69:5b:30:0f (capab=0x411 status=0 aid=2)
[  119.522259] wlan0: associated
[  119.523002] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  119.840039] Intel AES-NI instructions are not detected.
[  119.976906] padlock_aes: VIA PadLock not detected.
[  129.770718] wlan0: no IPv6 routers present


[  256.096324] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  256.096326] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  256.096329] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  257.539308] wlan0: authenticate with 00:23:69:5b:30:0f (try 1)
[  257.541105] wlan0: authenticated
[  257.541129] wlan0: associate with 00:23:69:5b:30:0f (try 1)
[  257.543374] wlan0: RX AssocResp from 00:23:69:5b:30:0f (capab=0x411 status=0 aid=1)
[  257.543378] wlan0: associated
[  273.100632] UDF-fs: Partition marked readonly; forcing readonly mount
[  273.126058] UDF-fs INFO UDF: Mounting volume 'DVD_MOVIE', timestamp 2002/04/15 14:14 (1ed4)

so no errors there. With my old drive I was getting a whole host of errors, none of which seem to be appearing now. Unfortunately they don't seem to be the cause of the problem.

Does anyone have any idea what's wrong or how I might diagnose this?

Just an update to the issue. I've just tried playing a DVD on the same computer running Windows 7 and there was no issue. So now I'm just confused. I assumed the error message at boot indicated a hardware issue, but Windows doesn't seem to care. So I guess it's just Ubuntu that has an issue.

share|improve this question
By the way, what is the brand of your DVD device? I have Lenovo Z500 and its built-in DVD seems to be be my problem. Possibly regionset story, but I couldn't reach permanent solution, since I use media from more than one region anyways. – Mateva Jun 20 at 9:02

To make your drive region free you need to flash new firmware onto it so that the drive itself will not check the region. This is knows as RPC1, search for New drives won't read "out of region" DVDs.

share|improve this answer

I'm going to guess it's a quirk with the SATA chipset on your motherboard and this drive that Windows has sorted but Linux has not yet.

Please respond with some more information about your hardware, and perhaps update your BIOS. It might be initializing the hardware incorrectly.

Also, start with CDs that you know aren't non-standard or drm-ified. DVDs have region lock; non-standard CDs introduce errors or do things to freak out DVD drives (certain drives don't read DVD-RW's in certain modes as some sort of rudimentary anti-copying measure) but a standard Audio CD is usually a lowest common denominator.

share|improve this answer
So after playing the DVD on Windows, it now works on Ubuntu. Someone else suggested that Windows set a region for my drive. Unfortunately I'm still getting error: cdrom read error at boot (after BIOS but before GRUB). If you have any ideas on how to fix that, that'd be fantastic. I have an ASUS Sabertooth X58 motherboard and a Lite-on IHAS124-04 DVD drive plugged into one of the 3 Gb/s SATA ports. I've tried removing the CD drive from the boot sequence, but that hasn't worked. I can try updating the BIOS, but I don't know how. Thanks for your help. – Kris Harper Jun 2 '11 at 4:35
up vote 1 down vote accepted

After booting into Windows and playing a disc there, the drive started to work in Ubuntu. Someone suggested that this is because Windows set the drive's region code. If you need to set a region code in Ubuntu, you can use this answer.

share|improve this answer

To enable greater DVD support open Accessories;Terminal and enter the following two commands:

sudo apt-get install ubuntu-restricted-extras

sudo /usr/share/doc/libdvdread4/
share|improve this answer
I've done both of those. It's the first thing I wrote in my question. – Kris Harper May 21 '11 at 19:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.