Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been struggling for some days now, and unfortunately not solved the problem: I am trying to install Bumblebee on Ubuntu (both 12.04 and 13.10) with a

Lenovo T440p with hybrid graphic cards (integrated intel)

The result is a pure disaster, the computer just stops working and does not even accept simple commands like sudo poweroff, then the programs crash down and the only way is shutting down brutally and installing ubuntu again. This without any single error message (depending on the guide followed)

Just for your information,

lspci | grep  VGA

gives

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
02:00.0 VGA compatible controller: NVIDIA Corporation GK208M [GeForce GT 730M] (rev a1)

I have followed a number of guides, but more or less what I am always doing is following, with some variations depending on the guide:

sudo apt-get purge nvidia
sudo apt-get update && sudo apt-get dist-upgrade
sudo add-apt-repository ppa:bumblebee/stable
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings
sudo add-apt-repository -r ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia
sudo apt-get dist-upgrade

I have noted that the laptop has problems after having installed bumblebee. I am also open to alternatives to Bumblebee, if there are any. Something like Primus should do, but as I read through this and other forums it is the pure death... Someone has some suggestions? What i need is just to run some few program on nvidia, use cuda and the rest on the integrated gpu. I am really sorry if I missed something, but I just passed to Ubuntu days ago so forgive any excessive noobness.

share|improve this question
    
I think you should follow official guide - wiki.ubuntu.com/Bumblebee. You are adding xorg-edgers ppa (I think it is for older ubuntu version), secondly you need to have kernel headers. But cuda set up could be bit more tricky How can I get nVidia CUDA or OpenCL working on a laptop with nVidia discrete card/Intel Integrated Graphics? –  Web-E Mar 30 at 20:04
    
Hi, That's what i've done as a first approach, but this does not really do either... It's kind of weird, probably I'm just messing around something, but I'm also trying to stick to the guides –  nico von snoopy Mar 30 at 20:06
add comment

2 Answers 2

You are installing nvidia twice. apt-get install bumblebee-nvidia pulls in the current nvidia package. Also, you only need to install one version of bumblebee, not both. Remove bumblebee. bumblebee-nvidia, and the nvidia driver, then run apt-get install bumblebee-nvidia primus. That should fix the issue.

share|improve this answer
    
Hi Chris, Thanks for the advice, I've tried it yesterday, but unfortunately it did not help much... here what i did: 0) install ubuntu 1) purge nvidia, 2) update && dist-upgrade 3) sudo add-apt-repository ppa:bumblebee/stable 4) sudo add-apt-repository ppa:xorg-edgers/ppa 5) sudo apt-get install bumblebee-nvidia primus END. this lead to the same crush, not even sudo gedit worked after.. I also updated the kernels but it did not help –  nico von snoopy Apr 1 at 16:41
add comment

I followed the instructions of Chris's answer, typing following commands (Just after having installed ubuntu):

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
sudo apt-get purge nvidia
sudo apt-get update && sudo apt-get dist-upgrade
sudo add-apt-repository ppa:bumblebee/stable
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo add-apt-repository -r ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install bumblebee-nvidia primus

and what i got is following error:

...
Setting up blablabla    
Setting up primus-libs-la32:i386 (20131127-1~preciseppa2) ...
Processing triggers for libc´bin ...
/var/lib/dpkg/info/libc-bin.postinst: 1: /var/lib/dpkg/info/libc-bin.postinst Syntax error: word unexpected (expecting ")")
dpkg: error processing libc-bin (--configure):
subprocess installed post-installation script returned error exit status
E: Sub-process /usr/bin/dpkg returned an error code (1)

As you can see, after having installed bumblebee i get a strange error message, and even normal commands (like sudo reboot) won't answer after that:

user@snoopy:~$ sudo reboot
/sbin/reboot : 1: /sbin/reboot: Syntax error: ")" unexpected

... i have to shut down the pc violently and reinstall everything...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.