Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have a Nvidia GT 630 with two LG Flatron E2242 screens connected. One of them is connected with a DVI/VGA connector because the card has 1 DVI and 1 VGA output.

The driver (got the latest one) can't query the one connected with the DVI/VGA connector for its EDID and I can't get it to work on a resolution bigger than 640x480.

How can I get it to work on 1920x1080 like the other one?

share|improve this question
What drivers are you using? What version of Ubuntu? What other hardware is in the computer? Is it a desktop or laptop? – ChrisR. Mar 30 '14 at 20:15
It's a desktop. Ubuntu 12.04. I'm using the 334.16 drivers. – santirivera92 Apr 8 '14 at 20:13
I've got almost the same configuration, but I linked my screens with DVI + HDMI and it's working fine. – MrVaykadji Apr 8 '14 at 20:38
My screens only have VGA input – santirivera92 Apr 8 '14 at 20:46
Looking at the LG specs online for the monitor, I see 2 connections. DVI-D and VGA. Are you sure you have the correct model? – Ghostwalker Apr 9 '14 at 2:49

2 Answers 2

I experienced this problem with a SANSUI HDMI/PC tv/monitor. My issue resulted from the SANSUI incorrectly reporting it's EDID. The solution is to use xrandr to add a mode manually to the problematic device. If the mode you want to add to your output already exists you can skip steps 2 and 3

  1. Type "xrandr" without any arguments which by default will list the devices and the modes currently associated with them. In my case xrandr reports the "output" device name for the SANSUI as CRT1.

  2. Use "cvt" to create a mode line to work with. (60 is the refresh rate)

    $ cvt 1920 1080 60
    Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
  3. Add this as a new mode to the xrandr database

    $ xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
  4. Associate the mode with the problematic output device

    $ xrandr --addmode CRT1 "1920x1080_60.00"
  5. We still need to select the new mode as the active mode for the output device

    $ xrandr --output CRT1 --mode "1920x1080_60.00"

NOTE: If the modeline doesn't work as reported by cvt try leaving off the other parameters besides the dimensions and refresh rate when creating a new mode.


share|improve this answer
Ok, the faulty monitor is this one: DVI-I-0 connected 640x480+0+0 (normal left inverted right x axis y axis) 0mm x 0mm 640x480 59.9*+ 320x240 60.1 When I try to add the mode, I get this. $ xrandr --addmode DVI-I-0 "1920x1080_60.00" X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 18 (RRAddOutputMode) Serial number of failed request: 31 Current serial number in output stream: 32 – santirivera92 Apr 13 '14 at 21:56

The solution is about adding custom edid.bin monitor file to xorg.conf you can doing that by following this steps.

Before you do anything unplug DVI cable and plug the VGA cable so you can get the property edid file for your monitor. But if you don't have VGA cable then use windows for dumping the file.

  • first of all you have to install NVIDIA driver:

    1. download nvidia driver .run from
    2. Hit CTRL+ALT+F1 then login
    3. type sudo service lightdm stop then sudo init 3
    4. uninstall any previously installed driver
    5. I'm not sure if it necessary but just in case sudo apt-get dist-upgrade
    6. install driver by typing sudo sh and following farther instruction reboot
  • skip previously steps if you have installed nvidia driver

  • open NVIDIA X Server Settings, from DFP-0 section dump the EDID file by hitting Acquire EDID button and save it to Desktop, then save xorg.conf by hit save to X Configuration file (note that you have to be root to do that)

  • copy EDID file to /etc/X11/ by typing in terminal:

    sudo cp /Desktop/filename.edid /etc/X11/filename.edid

  • then open xorg.conf sudo gedit /etc/X11/xorg.conf and add the following line to the Device Section:

Option "CustomEDID" "DFP-0:/etc/X11/filename.edid"

like this:

Section "Device"

Identifier "nVidia"

Driver "nvidia"

Option "CustomEDID" "DFP-0:/etc/X11/filename.edid"


  • Exit and save, then reboot. Now you can plug the DVI cable. Thats all
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.