Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I upgraded to Ubuntu 11.04 from 10.10, my compiz configuration stopped working - I have no cube effects and preview files and some other compiz stuff.

I have a Intel x4500 (00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03))

glxinfo

name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: Brian Paul
server glx version string: 1.4 Mesa 7.11-devel

I have removed compiz gnome (with --purge) and install again, nothing works.

I'm using the default Ubuntu desktop (no unity)

Any idea how can I fix this?

share|improve this question

2 Answers 2

Compiz is disabled by default if you're using classic desktop.

First you need to disable Ubuntu Unity Plugin from CompizConfigSettings-manager.

Then you can run compiz with:

compiz --replace

You may also want to make a startup task to run compiz every time you boot Ubuntu.

You can do this from Preferences -> Startup Applications

share|improve this answer

Same card here. Open the terminal and type:

unity --reset

It will reset the profiles in compiz and everything should work as expected on a default behaviour.

If you want to enable the cube, ccsm has a bug. Here's my profile with the cube enabled to just load it into the unity profile in ccsm.

http://ubuntuone.com/p/sOi/

share|improve this answer
    
I have to say, if you just want gnome with compiz effects, this command also reset the default profile for it too. –  David Rando May 21 '11 at 9:56
    
I don't use unity just classic desktop –  fazi May 23 '11 at 9:14
    
that doesn't matter. That command reset all the profiles (Unity and Classic Gnome) for Compiz. Now you're using Compiz 0.9 instead of 0.8 a reset doesn't hurt and you can configure compiz the way you want after that. –  David Rando May 23 '11 at 13:16
    
tryed and this waht I got :( Window created on XQueryTree, map state isViewable? 1 Initializing bailer options...done Initializing detection options...done Initializing composite options...done Compiz (opengl) - Fatal: Software rendering detected Compiz (bailer) - Info: Ensuring a shell for your session –  fazi May 23 '11 at 14:12
    
Yeah, that's the usual. But i guess after doing that and restart, you're having the same problem, right? –  David Rando May 23 '11 at 21:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.