Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I try and boot up any distro I get stuck at the syslinux line with a blinking cursor. I know this question has been asked many times before but every answer I found is from years ago, which none seemed to have worked for me, and I’m not sure if their even applicable to newer versions of the distros I've used.

I don't have access to a cd burner and I can't order a disk with a specific distro installed, so this common answer is out of the question for me.

I'm currently running on Windows 7 on an acer aspire.

I've tried 5 distros (ubuntu, zorin, puppy, fedora and mint), same outcome in all of them.

I’ve tried creating my live usb with unetbootin and pendrive, same outcome and I’ve checked MD5SUM, everything’s fine.

I used 3 different usb sticks, an hp 10 gig, a sandisk 8 gig(i've read sandisk usb's have issues and I’ve tried the fixes for it, still nothing), and a 7 gig with a worn off label.

I've tried formatting these stick in FAT32, exFat, and ntfs (these are the only options I’m given when I format them) same outcome every time.

I've tried with partitioning my system (with windows disk manager and again with gparted) and without partitioning anything, no change, and I cant even get to the point to let ubuntu's partitioner start up.

I used the solution at Wont boot from USB, stops at SYSLINUX copyright and can't install with usb pen drive, SYSLINUX problem, same results.

I have been able to get ubuntu to install using wubi but the 30 gig partition it does is nowhere near enough memory for me.

I just want to be able to use my usb to install a distro, I’m not trying to make a persistent usb to carry all my data with it or anything like that.

Can anybody tell me what I could try next, or what additional info I should try and give?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

have you tried using dd command. the usage is sudo dd if=< /path/to/your/iso > of= < /your/target/device >.

let me warn you firsthand, you can recover a partition accidentally deleted but, if you write your iso to the wrong drive using dd, you cannot recover the data from the overwritten partiion.. use it with caution. to find out which device you want to write on, type 'lsblk' in terminal. it will give you the list of devices. for example, if it says that /dev/sdb is 3.73 gb with a partition sdb1, with ubuntu.iso in your home folder, your command should be

sudo dd if=/home/username/ubuntu.iso of=/dev/sdb

if you want to reuse the pendrive, go to gparted and select your device correctly and in menu bar click device >> crate partition table. it will create a ms-dos partition table which is what we need. now, we can create partitions on it. click on new and then select ntfs and name it. i think you can understand the later steps.

share|improve this answer
    
I'm still new to linux commands and partitioning, so do you mind if I ask a few questions about this first? 1) "if you write your iso to the wrong drive using dd, you cannot recover the data from the overwritten partiion" stupid question, but does this mean if I decide I want to use another distro or stop using ubuntu, the space I allocated for it will be completely unusable? or could I later delete said partition with the written iso to get the space back? 2) will /dev always be at the start "of=/" sorry, really new to linux and I don't want to kill my only computer, and can I specify a –  jc_aeon Mar 30 at 19:42
    
specific partition with of=/dev/sdb/sdb2? –  jc_aeon Mar 30 at 19:42
    
dd if=ubuntu.iso of=/dev/sdb means that you bluntly copy the contents of ubuntu.iso onto the device /dev/sdb which is your pendrive. there is nothing like /dev/sdb/sdb2. it is /dev/sdb2. by the way, if you write it to /dev/sdb then your pendrive will now be detected as cd(because of blunt copying) and you can boot from it. if you say of=/dev/sdb2, the partition 2 of your usb will be overwritten with iso files. your device is still usb and it will not live boot. you can issue dd over the same pendrive for another os boot(any linux iso). –  aveemashfaq Mar 30 at 19:50
    
Ah, I had a completely different idea of what dd would do. It will take a while for me to download another iso but I'll give this a shot, thanks. –  jc_aeon Mar 30 at 19:58
    
two weeks of headaches and scanning through the depths of google and nothing, then one command in the terminal solves everything. Thanks, this worked perfectly. Out of curiosity though, do you happen to know how this procedure can be done in windows without any linux distro? Just for future reference in case wubi stops working. –  jc_aeon Mar 30 at 22:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.