Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Inspiron Mini 1012 running Ubuntu 10.04 and Windows 7 Starter in a dual-boot configuration.

The CPU runs much cooler in Windows than it does in Ubuntu, even when the CPU has been idling. For example, I'm in Ubuntu now, the CPU has been idling for some time, and the CPU temperature is 72 C according to lm-sensors and coretemp.

The machine actually overheated in Ubuntu at one point, just from running the CPU at 100% for an extended period of time. Again, this problem only occurs in Ubuntu - I have never noticed a heat issue in Windows.

I have tried using the CPU Frequency Scaling Monitor GNOME applet to set my CPU speed to 1GHz (instead of 1.67GHz) and Powersave mode, but this does not seem to affect the idle temperature.

Here is /proc/cpuinfo:


processor   : 0
vendor_id   : GenuineIntel
cpu family  : 6
model       : 28
model name  : Intel(R) Atom(TM) CPU N450   @ 1.66GHz
stepping    : 10
cpu MHz     : 1000.000
cache size  : 512 KB
physical id : 0
siblings    : 2
core id     : 0
cpu cores   : 1
apicid      : 0
initial apicid  : 0
fdiv_bug    : no
hlt_bug     : no
f00f_bug    : no
coma_bug    : no
fpu     : yes
fpu_exception   : yes
cpuid level : 10
wp      : yes
flags       : fpu vme de tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm
bogomips    : 3325.06
clflush size    : 64
cache_alignment : 64
address sizes   : 32 bits physical, 48 bits virtual
power management:

processor   : 1
vendor_id   : GenuineIntel
cpu family  : 6
model       : 28
model name  : Intel(R) Atom(TM) CPU N450   @ 1.66GHz
stepping    : 10
cpu MHz     : 1000.000
cache size  : 512 KB
physical id : 0
siblings    : 2
core id     : 0
cpu cores   : 1
apicid      : 1
initial apicid  : 1
fdiv_bug    : no
hlt_bug     : no
f00f_bug    : no
coma_bug    : no
fpu     : yes
fpu_exception   : yes
cpuid level : 10
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm
bogomips    : 3325.07
clflush size    : 64
cache_alignment : 64
address sizes   : 32 bits physical, 48 bits virtual
power management:

Does anyone have any advice as to how I can get my CPU to run cooler under Ubuntu?

Update:

Here is the output of powertop, after running it for about a minute:


Cn                Avg residency       P-states (frequencies)
C0 (cpu running)        (13.7%)         1.67 Ghz     2.8%
C0                0.2ms ( 0.0%)         1333 Mhz     0.3%
C1 mwait          0.3ms ( 2.2%)         1000 Mhz    96.9%
C2 mwait          0.5ms (14.2%)
C4 mwait          0.8ms (69.9%)

Wakeups-from-idle per second : 1303.9 interval: 10.0s
Power usage (ACPI estimate): 13.3W (2.7 hours)

Top causes for wakeups: 33.4% (611.7) chromium-browse 26.5% (483.7) PS/2 keyboard/mouse/touchpad interrupt 17.7% (324.3) [extra timer interrupt] 7.8% (142.9) [kernel scheduler] Load balancing tick 2.3% ( 41.2) ekiga 1.9% ( 34.0) [eth1] 1.6% ( 29.4) rhythmbox 1.3% ( 24.5) USB device 1-8 : USB2.0-CRW (Generic) 1.3% ( 24.2) Xorg 1.1% ( 19.8) desktopcouch-se 1.0% ( 18.5) [ehci_hcd:usb1, uhci_hcd:usb2] 0.8% ( 15.5) [acpi] 0.6% ( 10.8) [kernel core] hrtimer_start (tick_sched_timer) 0.4% ( 6.9) [kernel core] add_timer (wl_timer) 0.3% ( 5.3) parcellite 0.2% ( 3.6) gwibber-service 0.2% ( 3.0) [Rescheduling interrupts] 0.2% ( 3.0) wpa_supplicant 0.1% ( 2.3) python 0.1% ( 2.3) gnome-terminal 0.1% ( 2.1) beam.smp 0.1% ( 1.9) multiload-apple 0.1% ( 1.8) NetworkManager

Update:

Upgrading to kernel 2.6.38-1 via PPA actually seems to make the wakeups-per-second as bad or worse:


PowerTOP version 1.12      (C) 2007 Intel Corporation                                                                            

Cn                Avg residency       P-states (frequencies)
C0 (cpu running)        (13.2%)         1.67 Ghz     9.6%
polling           0.0ms ( 0.0%)         1333 Mhz     1.1%
C1 mwait          0.5ms ( 4.2%)         1000 Mhz    89.3%
C2 mwait          0.7ms (50.8%)
C4 mwait          0.5ms (31.8%)

Wakeups-from-idle per second : 1465.2   interval: 10.0s                                                                                                                   
Power usage (ACPI estimate): 13.5W (3.6 hours) (long term: 12.6W,/3.9h)

Top causes for wakeups:
  35.8% (483.6)   PS/2 keyboard/mouse/touchpad interrupt
  27.0% (364.4)   chromium-browse
  21.0% (284.5)   [extra timer interrupt]
   2.7% ( 36.0)   kworker/0:0
   2.5% ( 34.3)   [kernel scheduler] Load balancing tick
   2.5% ( 33.8)   Xorg
   1.5% ( 19.9)   desktopcouch-se
   1.1% ( 15.1)   [acpi] 
   0.0% (  0.1)D  flush-8:0
   0.9% ( 12.5)   USB device  1-8 : USB2.0-CRW (Generic)
   0.9% ( 12.0)   [ehci_hcd:usb1, uhci_hcd:usb2] 
   0.1% (  0.7)D  upowerd
   0.6% (  8.3)   parcellite
   0.5% (  7.3)   [ahci] 
   0.5% (  6.1)   gnome-terminal
   0.3% (  3.6)   gwibber-service
   0.2% (  3.0)   [kernel core] timer_action (ehci_watchdog)
   0.2% (  2.8)   [kernel core] hrtimer_start (tick_sched_timer)
   0.2% (  2.2)   python
   0.1% (  2.0)   multiload-apple
   0.1% (  2.0)   beam.smp
   0.1% (  1.7)   [Rescheduling interrupts] 
   0.1% (  1.6)   [eth0] 

The program 'upowerd' is writing to file 'history-rate-DELL_2T6K207N-52.d' on `/dev/sda5`. This prevents the disk from going to powersave mode.

 Q - Quit   R - Refresh  
0$ notes  1$ todo  2$ dev1  3$ dev2  4$ dev3  5$ srv  (6*$bash)  7-$ bash                                                                                    05/26  2:03PM

share|improve this question
    
Can you post the version no. of you kernel, by pasting the output of uname -r in your question? –  theTuxRacer May 20 '11 at 15:33
    
It's the stock, up-to-date 10.04 kernel: 2.6.32-31-generic –  jbeard4 May 20 '11 at 15:47
1  
Even with a few browsers and IDE's open, my CPU wakeups never exceed 600. Also, even running my Core 2 Duo at 100% for over an hour, the temperature won't reach 72 C. I'm thinking it's a kernel issue. Try installing kernel 2.6.34 from the Ubuntu kernel PPA: kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-lucid –  Xiao-Long Chen May 22 '11 at 19:19
    
Chen, that's a good point of reference, thank you. I'll try upgrading the kernel via PPA - or I might just bite the bullet and try to dist-upgrade to Natty. –  jbeard4 May 22 '11 at 19:37
    
Try my solution and let me know if it works. It seems that we have the same problem <br/> –  vanjadjurdjevic Jan 3 '12 at 18:04

5 Answers 5

It is not really an anwser more a proposal how to proceed. For me it seems impossible that a CPU that is idling should produce a heat of 72 degree celcius. Do you mean by idling on the os is running or did you check the load of the CPU?

Install powertop from synaptics and start the programm in the terminal by "sudo powertop" the programm will tell what the CPU is really doing. It tells you also which activities keeps the CPU busy.

share|improve this answer
    
I forgot a "impossible" after it seems in the second sentence. Sorry. –  dago May 22 '11 at 17:09
    
I checked the CPU load using top. I also have the system monitor applet which shows me a graph of the CPU load over time. By "idle" I mean that the CPU load is very low or is none. –  jbeard4 May 22 '11 at 17:55
    
I posted the output of powertop. –  jbeard4 May 22 '11 at 17:55
2  
This seems quite normal. How is your fan behaving? Some laptops/netbooks have fancontrol problems under ubuntu. The attached link should allow you to read out your sensors. May be you have a dedicated sensor for the fan. zefanjas.de/2008/12/03/cpu-temperatur-lufterdrehzahlen-etc-mit-ubuntu-auslesen/ –  dago May 22 '11 at 18:31
    

Have you checked your CPU Frequency?

Usually my laptop only heats up when the frequency is higher than normal for extended periods.

You can control the frequency by adding the "cpu frequency applet" to the panel (if you are using gnome).

share|improve this answer
    
As stated in the question, I have tried using the CPU Frequency Scaling Monitor GNOME applet to set my CPU speed to 1Ghz (instead of 1.67Ghz) and Powersave mode, but this does not seem to affect the idle temperature. –  jbeard4 May 26 '11 at 17:35

Install jupiter, either jupiter or acpi=off, it completely stopped my power hogging problem.

acpi= off stopped most of it but with jupiter installed it has never come back. The freq scaling applets don't always stay on the panel for me.

share|improve this answer

I see two possibilities. One is that your board's ACPI stuff doesn't work properly(the fan doesn't spool any faster under load). Try acpi=off on the kernel line. Another possibility is that the kernel is tuned to a higher than normal polling frequency(as some users suggest in youtube videos to make the desktop more responsive...imho a fail). If you aren't using a stock kernel, use one. If you are, try with acpi disabled. If your fans are louder but your temp stays lower file a bug or accept it.

Just my 2 cents.

share|improve this answer
    
Thanks for the reply. I'm using a stock kernel, and the machine is fanless. –  jbeard4 May 28 '11 at 20:02

Had the same issue in my Dell inspiron with dual boot. I tried jupiter which brought down the temperatures a little and i tried acpi=off which by the way caused one of my processor cores not show up in ubuntu. The problem was eventually tracked down to faulty display drivers with the radeon GPU. Ater failed attempts of installing the amd catalyst display driver the only remedy i found was to turn off the radeon GPU, which brings the temperature down to values comparable to windows 7 in idle.

Detailed steps of turning off the GPU can be found here: How do I turn off the Radeon GPU ono my HP Pavilion DM4?

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eric Carvalho Jul 20 '13 at 19:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.