Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After successfully installing Ubuntu and logging in to the Unity desktop, I followed the prompts to enable the proprietary display drivers.

After rebooting, the Unity desktop is now entirely unresponsive. The mouse pointer moves but I can't do anything.

After some research, it looks like it is specifically a problem with these drivers and Unity, so I should be OK with, say, the classic Gnome desktop.

Unfortunately, I enabled auto login so I don't get the chance to chose another desktop. Can I fix this from the CLI?

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

Create or modify the file /etc/gdm/custom.conf, and write the following content:

[daemon]
TimedLoginEnable=false
AutomaticLoginEnable=false
TimedLogin=enzotib
AutomaticLogin=enzotib
TimedLoginDelay=30
DefaultSession=gnome

where enzotib should be replaced with your username and gnome could be replaced by

  • gnome - for Ubuntu
  • gnome-classic - for Ubuntu classic
  • gnome-2d - for Ubuntu classic (no effects)
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.