Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I installed 13.10 on a partition that had Mint on it. When trying to add any ppa

sudo add-apt-repository ppa:snwh/moka-gtk-theme-daily

I get the following error:

sh: 1: /usr/lib/linuxmint/mintSources/ not found

How can I point it to the right file?

Thanks in advance.

EDIT: I just found out that adding new PPAs via the software and updates tool works. Not a perfect solution, but it works.

share|improve this question

closed as off-topic by Avinash Raj, karel, i08in, chaskes, Seth Mar 30 '14 at 16:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Avinash Raj, karel, i08in, chaskes, Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

Are you running linux mint? – Avinash Raj Mar 30 '14 at 9:59
If you are not running Mint you need to re-install and not upgrade to Ubuntu if you want to switch to Ubuntu. – Rinzwind Mar 30 '14 at 10:01
I installed Ubuntu with the option to delete the existing Mint installation. – ringgord Mar 30 '14 at 11:07
There doesn't appear to be anything wrong with the ppa. As @Rinzwind says, you appear to have problems from not reformatting the partition when switching. – chaskes Mar 30 '14 at 14:36
You should really do a clean install. – Seth Mar 30 '14 at 18:13

1 Answer 1

up vote 0 down vote accepted

It can be that this PPA is tailored towards Mint and can't be installed to Ubuntu. Try other PPAs.

If they all fail, bad luck. You messed up Ubuntu installation. You have leftover Mint files in your Ubuntu partition. It can't be repaired because nobody know what exactly was left. Reinstall your Ubuntu, don't forget to either format root partitions or remove all folders that are not cleanly your own from it.

share|improve this answer
I solved this by deleting /usr/local/bin/add-apt-repository and /usr/local/bin/apt-add-repository, (script/symlink left over by mint), then sudo apt-get --purge remove python-software-properties software-properties-common, then re-installing them. I really didn't feel like doing a clean install, and haven't had any issues except a few with apt, all which were resolvable without much hassle. – Raskol Jan 12 at 3:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.