Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop has Ubuntu 10.10 and is connected to my router with full internet access, yet I can't ping it from other computers on my LAN. I tried the following:

  • I can successfully ping those other computers from my Ubuntu laptop, so I didn't accidentally connect to someone else's network.
  • I can successfully ping my Ubuntu laptop from itself, though I don't know if that means anything.
  • I haven't messed with iptables at all, so it currently doesn't have any rules set that would cause it to reject anything.
  • I made a DHCP reservation for my laptop's MAC address in my router to make sure I was always using the correct IP address.

Please note that I am using a "command line only" install of Ubuntu, so I can't use any GUI network config tools. The reason I want to ping it is because I am trying to run an NFS server on the laptop, yet despite correctly setting it up I cannot access the NFS volume on another computer because it isn't even visible on the network right now.

share|improve this question
2  
Please paste input/output from when you try ti ping your laptop. –  user606723 Aug 10 '11 at 14:27
    
This is really about the other computers on your LAN. They can not ping OR connect to the Ubuntu laptop. Is this a heterogeneous network? (Linux, Windows, Mac, etc.) –  david6 Nov 25 '11 at 2:26

2 Answers 2

You don't mention whether or not you attempted to ping via hostname or ip address. If by hostname, WINS is not a standard part of Linux (esp a basic install), so most consumer routers and Windows boxes won't be able to connect via hostname. Your router may have a method of manually setting hostnames to a specific MAC or IP address, which could solve the problem. If you have all Linux boxes and are having the problem, try defining the names in /etc/hosts. Finally, try installing WINS if that's the route you like (part of SAMBA): https://help.ubuntu.com/community/Samba/SambaServerGuide

share|improve this answer

Not a solution, but a diagnostic tool: try to reach your computer via TCP to rule out the case that something funky is going on with ICMP packets. On the receiving host run

nc -l 8090

while on the other, run

echo hi | nc ip.of.computer 8090

Of course you need to replace of.of.computer with the computer's ip address such as 192.168.0.101. If all goes well, you should see "hi" in the output of the computer you're trying to reach. If not, there is something wrong with your routing or a firewall is blocking incoming packets.

share|improve this answer
    
Thanks for the suggestion, I'll try it as soon as I get home today and will comment again with the results. I should note, though, that I can't connect to the NFS server either, so I don't think it's just an ICMP issue. –  oskar May 20 '11 at 14:44
    
Just got back home, and no, the receiving computer did not receive the message. –  oskar May 20 '11 at 19:55
    
But it does work the other way round? That seems pretty weird. Double-check IP addresses. Otherwise something might be wrong with the router / wifi / cables. –  loevborg May 20 '11 at 20:08
    
Oh make sure that the router doesn't have any built-in firewall between the wifi and the LAN. –  loevborg May 20 '11 at 20:09
1  
I actually discovered something which offers a clue. If I first ping my windows 7 computer from my ubuntu laptop, and then immediately try to ping the other direction, it works. However if I wait even ten or fifteen seconds, pinging the ubuntu laptop doesn't work. To me, this sounds like a firewall is running somewhere. Technically there is an SPI firewall running on the router, but turning it off doesn't seem to change this behavior. –  oskar May 20 '11 at 21:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.