Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two servers, using one for prod and one for dev. They are with different providers, and one is running Xen and the other OpenVZ (both running Ubuntu but 8.04 and 10.10 respectively). I've been having an issue with the OpenVZ server setting up my iptables because apparently its missing some kernel modules. When I run lsmod | grep ip I get these results:

Xen-

$ lsmod | grep ip
ipt_LOG                 8192  1 
nf_conntrack_ipv4      21904  2 
nf_conntrack           79344  2 nf_conntrack_ipv4,xt_state
ipt_REJECT              6528  3 
iptable_filter          4608  1 
ip_tables              24232  1 iptable_filter
x_tables               23432  6 ipt_LOG,xt_limit,xt_tcpudp,xt_state,ipt_REJECT,ip_tables
ipv6                  313384  18 
multipath              11008  0 
md_mod                 89500  6 raid10,raid456,raid1,raid0,multipath,linear

OpenVZ-

BLANK, there is nothing returned...

So my questions are, 1) Why am I getting nothing returned for the OpenVZ server, and 2) How do I load the necessary modules?


UPDATE:

This is the result of trying modprobe

$ modprobe nf_conntrack
WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
FATAL: Module nf_conntrack not found.
share|improve this question
    
Does your kernel modules directory exist? ls -d /lib/modules/$(uname -r) –  Lekensteyn May 20 '11 at 17:14
    
nope, it doesn't, which I find very strange but don't know what to do about it haha, any ideas? The directory /lib/modules/$(uname -r) exists but there is no kernel folder in there –  GiH May 20 '11 at 18:53
    
Does OpenVZ support loading kernel modules? Try searching on serverfault.com –  Lekensteyn May 20 '11 at 19:33
    
Well, it seems by my research that the provider needs to take care of that by the host node, and then make things available to the container... the only problem is my provider hasn't been responding to my support requests! I'll report back when they do I guess, but if anyone has any other ideas or knows how to do this please let me know. I also just read in a comparison between Xen and OpenVZ that OpenVZ does not support loading kernel modules... booooo, thanks! webhostingtalk.com/archive/index.php/t-963377.html –  GiH May 20 '11 at 21:10
add comment

1 Answer 1

up vote 0 down vote accepted

It turns out that I am unable to load kernel modules to a container, since all containers on OpenVZ platforms use the same kernel (unlike Xen). What I needed to do was get in touch with my provider and have them enable iptables for me. After that all rules worked.

Funny thing is I still don't have any output by typing lsmod | grep ip and there still doesn't seem to be any kernel folder in my /lib/modules/$(uname -r) folder. I guess this is not accessible from within a container.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.