Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

All operating systems freeze sometimes, and Ubuntu is no exception. What should I do to regain control when...

  • just one program stops responding?
  • nothing at all responds to mouse clicks or key presses?
  • the mouse stops moving entirely?

In what order should I try various solutions before deciding to pull the power plug?

What should I do when starting up Ubuntu fails? Is there a diagnostic procedure I can follow?

share|improve this question

44 Answers 44

up vote 290 down vote accepted

When a single program stops working:

When a program window stops responding, you can usually stop it by clicking the X-shaped close button at the top left of the window. That will generally result in a dialog box saying that the program is not responding (but you already knew that) and presenting you with the option to kill the program or to continue to wait for it to respond.

Sometimes this does not work as expected. If you can't close a window by normal means, you can hit Alt+F2, type xkill, and press Enter. Your mouse cursor will then turn into an X. Hover over the offending window and left-click to kill it. Right clicking will cancel and return your mouse to normal.

If your program is running from a terminal, on the other hand, you can usually halt it with Ctrl+C. If not, find the name and process ID of its command, and tell the program to end as soon as possible with kill [process ID here]. It sends the default signal SIGTERM (15). If all else fails, as a last resort send SIGKILL (9): kill -9 [process ID here]. Note that you should only use SIGKILL as a last resort, because the process will be terminated immediately by the kernel with no opportunity for cleanup. It does not even get the signal - it just stops to exist.

(Killing a process by kill -9 allways works if you have the permission to kill. In some special cases the process is still listed by ps or top (as "zombie") - in this case, the program was killed, but the process table entry is kept, becuse it's needed later.)

When the mouse stops working:

If the keyboard still works, press Alt+F2 and run gnome-terminal (or, if these fail to launch, press Alt+Ctrl+F1 and login with your username and password). From there you can troubleshoot things. I'm not going to get into mouse troubleshooting here, as I haven't researched it. If you just want to try restarting the GUI, run sudo service lightdm restart. This should bring down the GUI, which will then attempt to respawn, bringing you back to the login screen.

When everything, keys and mouse and all, stop working:

First try the Magic SysReq method outlined in Phoenix' answer. If that doesn't work, press the Reset button on the computer case. If even that doesn't work, you'll just have to power-cycle the machine.
May you never reach this point.

share|improve this answer
I've recently discovered that, rather than the "ps $options | grep $process_name" referenced above, one can just enter "pgrep $process_name" to achieve approximately the same result (for certain values of $options). – koanhead Jun 4 '11 at 13:45
One should never recommend kill -9 right off the bat. Once should instead attempt to kill the process with less drastic signals first, and only use -9 if all else fails. – Scott Severance Sep 28 '12 at 4:18

After suffering with this over a year I think I worked around the problem by using Xfce as the desktop environment. I simply installed it via command prompt: sudo apt-get install xfce4

I have a 2009 PC with in-built graphics and it intermittently had problems every time graphics settings were adjusted (whether via Ubuntu's auto updates or not I'm not sure).

I suppose I could have given Unity 2D a try but xfce works.

share|improve this answer

In my case compiz lead to some sort of freezing Ubuntu: I can move mouse cursor, but mouse clicks do nothing. Common keyboard shortcuts do not work too. So, my recipe is restarting compiz

  1. Press Ctrl + Alt + F1

  2. Run the following command:

    killall -9 compiz

  3. Press Ctrl + Alt + F7

share|improve this answer

For those who:

  • have screen freezes but applications are still working
  • and you can do Ctrl + Alt + F1
  • and you have no other option but to restart (service lightdm restart doesn't work)
  • and you have too many applications open and don't want to lose your session

Maybe you can:

  • go do the Ctrl + Alt + F1
  • run pm-suspend (will suspend the machine)
  • start the machine; you should get the machine back to the state before the screen freezes (at least for me it did)

I've tried all solutions suggested above, but none of them work or part of it worked but I was still forced to restart the machine and lose all running applications. This is not the best solution but at least I don't lose the applications I need when working.

share|improve this answer

If it locks up completely, you can REISUB it, which is a safer alternative to just cold rebooting the computer.


While holding Alt and the SysReq (Print Screen) keys, type REISUB.

R:  Switch to XLATE mode
E:  Send Terminate signal to all processes except for init
I:  Send Kill signal to all processes except for init
S:  Sync all mounted file-systems
U:  Remount file-systems as read-only
B:  Reboot

REISUB is BUSIER backwards, as in "The System is busier than it should be", if you need to remember it. Or mnemonically - R eboot; E ven; I f; S ystem; U tterly; B roken.

This is the SysReq key:

SysReq key

NOTE: There exists less radical way than rebooting the whole system. If SysReq key works, you can kill processes one-by-one using Alt+SysReq+F. Kernel will kill the mostly «expensive» process each time. If you want to kill all processes for one console, you can issue Alt+SysReq+K.

NOTE: You should explicitly enable these key combinations. Ubuntu ships with sysrq default setting 176 (128+32+16), which allows to run only SUB part of REISUB combination. You can change it to 1 or, which is potentially less harmful, 244. To do this:

sudo nano /etc/sysctl.d/10-magic-sysrq.conf

and switch 176 to 244; then

echo 244 | sudo tee /proc/sys/kernel/sysrq

It will immediately work! You can test this by pressing Alt+SysReq+F. For me, it killed active browser tab, then all extensions. And if you will continue, you can reach X Server restart.

More info on all the Alt+SysReq functions here.

share|improve this answer
In the event you're forced to do this, do it slowly. Let a few seconds pass in between each keypress so that the commands you're invoking have a chance to finish before you go to the next one. – Andrew Lambert Apr 24 '11 at 8:22
In case you like mnemonics: Raising Elephants Is So Utterly Boring, or Reboot Event If System Utterly Broken. I've also seen it as RSEIUB (Raising Skinny Elephants is Utterly Boring). – Siegfried Gevatter Apr 26 '11 at 14:19
I actually came up with this one and try to remember it this way: "Reset System Environment In UBuntu". or "Reset Environment In System UBuntu". – Luis Alvarado Aug 14 '12 at 21:32
What do you do if you're using a Mac that has no SysRq key? – Cerin Jan 9 '13 at 23:22

Before you try the next key combination, please remember that Ctrl+Alt+F7 brings you back. Remember? Really? OK, then: If the Ubuntu GUI doesn't show up or freezes just use Ctrl+Alt+F1 to switch to a terminal.

You should have pressed Ctrl+Alt+F7 to see this message again.

It is the easiest solution, but not permanent, after that your Ubuntu can continue to freeze, but you can repeat this process every time, when Ubuntu freezes. :)

share|improve this answer

My ubuntu is super prone to freezing (probably 20 odd times a day). I use the magic sysrq key too, but instead of using it to reboot or kill xserver, I use the 'f' command which calls oom_kill, effectively dropping a process. I've only ever seen this drop chrome tabs (as I tend to have quite a few heavyweight ones open at a time). Anyway, this get's me out of this mess 95% of the time.

So when my ubuntu freezes (locks up, mouse stops responding etc), I hold alt + sysrq and then hit f (if you don't do this correctly it will take a screenshot instead). I usually have to repeat this combo a couple of times before ubuntu spurs back to life.

I'd have given up on ubuntu a long time ago if I hadn't discovered this, hope it helps someone!

share|improve this answer

If you have tried all of the above and the freezing problem reminds, you might want to read what I did.

As the freezings had random appearance -though somehow connected with big, graphics-related CPU demands- I decided to stop thinking "digital" and going analog.

Just apply generous amounts of contact cleaner to CPU, RAM and anyother chip complex enough to show those tiny, thight to each other pins. They can as well stop conducting from micro-dust accumulation as falling into shortcut due to humidity. All in all, electrons running up and down is on the basis of it all.

IT WORKS! Some days after the cleaning (I used CRC 2-26) and a series of really brutal stress tests, my PC has never frozen again -may it work slower during the test, as natural.

So, for all of you getting sudden unexpected freezings, give up messing around with your O.S. beyond what's reasonable and do an exhaustive dust and contact cleaning.

Your hardware will appreciate.

share|improve this answer

I've had this happen a lot when compiz goes crazy and then I have to restart unity.

  1. Press Ctrl + Alt + F1

  2. Run the following command:

    unity restart
  3. Press Ctrl + Alt + F7

share|improve this answer
unity restart never needs to, and should never be, run with sudo. It should run as the currently loggged in user, never root. – Eliah Kagan Feb 6 '13 at 23:50

I have a simple fix for random freezes happening under Ubuntu 12.04 (kernel 3.5.0-41) on HP DV7, just use unity_2d :

sudo vi /etc/lightdm/lightdm.conf

Replace "user-session=ubuntu" with "user-session=ubuntu-2d"

sudo reboot

More info on

Memtest passed many times and it just happened from one day to the other, possibly after an upgrade. I just couldn't investigate the kernel panic, the whole system was locked and logs (when available) were not displaying anything relevant to me.

Has anyone has an idea about what is wrong with my graphics card for not supporting open GL anymore?

share|improve this answer

DoR and Phoenix has answered this well. To make this page more complete I would add:

If it is only X that is "broken", than you can use kernel to kill it:

SysRq + Alt + K

For laptops (depends on the model, typically needed if "SysRq" is written in blue):

Fn + SysRq + Alt + K (release Fn after pressing SysRq).

share|improve this answer

I have Ubuntu 12.04 LTS installed on Lenovo Thinkpad core i5, it kept on freezing completely and I had to manually restart it by power cycle. I solved it by updating my Ubuntu kernel to latest version. It might fix your problem too. Here are the instructions to do that:

1- Go here: Download 3 (maybe 4) debs to a folder somewhere:

  • linux-headers-VERSION-NUMBER_all.deb

  • linux-headers-VERSION-NUMBER_amd64.deb

  • linux-image-VERSION-NUMBER_amd64.deb

  • linux-image-extra-VERSION-NUMBER_amd64.deb # if available

2- Install the debs with whatever package manager front-end you use (is gdebi still around?), or use these commands:

cd /path/to/folder/where/you/put/the/debs
sudo dpkg -i *.deb

Source: How to update kernel to the latest mainline version without any Distro-upgrade?

share|improve this answer

you are suffering from a small problem that happens with Ubuntu and some video cards. Not to worry. It also happened to me. It happens because there are some missed bugs between the relation of Unity/Compiz, the system and the Video driver. This bugs of course are dealt with with newer, updated versions of Unit, Compiz, X or the video Driver.

The solution is to, when inside Unity and everything is slow and basically damaged, to go to TTY1, press CTRL+ALT+F1. When in the terminal, type your user and password to get to the prompt line. You can also get to the TTY when booting by pressing ESC or holding SHIFT, then on the GRUB menu, selecting recovery mode.

Now, there are several PPA I would recommend or other ways of doing this but to get to the point fast and have your system working do the following:

  1. Install Xorg Edgers PPA

    sudo add-apt-repository ppa:xorg-edgers/ppa sudo apt-get update

    Depending on your video card you can either install the 304 series, 310 Series, 313 Series or any newer one that appears there. I recommend always test the latest version and only if it throws a problem, then go down from there until you reach a version where everything works correctly. For example, if you have a GT 9500 or later (Like in my case to which I also have a 440 GT, 560 TI and 680 GTX) the only version that solves all my problems is the 313.18 that came out a couple of days ago. So I would do this:

    sudo apt-get install nvidia-313

    This would install the latest version of the 313 series. It fixes MANY video problems with compiz, unity and xorg. The 310 series also fixes many issues but have not tested that one with my video cards. The other Nvidia versions are nvidia-experimental-304 and nvidia-experimental-310 as of this writing.

  2. Reboot to test if your video card not works correctly with Ubuntu. If you happen to get any problems regarding Nvidia config file, simply open a terminal and type sudo nvidia-xconfig and reboot.

There are other nice questions that could also help like:

How can I update my NVIDIA driver?

Newest Nvidia Card - what driver should I install?

Can't install GTX 680 drivers on 12.04

What's the difference between the nvidia-current, and nvidia-current-updates packages?

Or even one that is more generic: How to correctly enable Desktop Cube in Unity 3D?

share|improve this answer

Freezes such as you have described can be both software and hardware related and as you have found sometimes frustratingly difficult to diagnose.


If this is a desktop PC look at your hardware-cards. For both laptops and desktops possibly acpi type issues.

It might be useful to temporarily simplify your configuration to have just the graphics card connected with a standard keyboard and mouse. All other cards should be removed.

For acpi related issues, try booting with noapic nomodeset in your grub boot option. Its also worth trying acpi=off although this could have other undesirable effects such as constant fan usage.

Also worth checking the bios version level and seeing if the vendor has a newer bios version. The readme notes should hopefully reveal if any newer version fixed crashes and freezes.


I note you have tried the standard 270 drivers but have failed due to freezes. Can you clarify if you had similar issues with the open-source driver? Obviously you will not get Unity during testing this.

Graphics freezing can be one of/or a combination of the driver/compiz/X/kernel

If you are willing to try any of the suggestions below first backup your system with a good backup tool such as CloneZilla. You will need an external media device to receive the image such as a large USB stick/drive or separate internal hard-drive.

Installing newer nVidia driver

Deactivate (uninstall) your current 173-nvidia driver using the Additional Drivers window.

There are a small number of important fixes primarily in the 275 stable but a small number also in the 280beta that fixed freezes - it is worth a shot to see if these apply to your graphics card. Unfortunately nvidia dont go into detail on which cards they specifically fix (readme.txt)

However - I would strongly recommend a backup unless you feel confident on reversing a nvidia install - especially since you had serious issues with the slightly older 270 drivers. I've used clonezilla countless times and it has always got me out of trouble. You do need a large external drive though - USB stick/external drive or a separate drive.

X Updates

The latest graphics drivers have been packaged in the x updates ppa.

Note - this will lead you away from the standard baseline - if upgrading in the future ppa-purge the PPA itself before upgrading.

You can also manually install the drivers from nVidia:

Try installing the latest nvidia stable 275 or 280 drivers - 32bit 280 drivers: ftp site and 64bit: 280 drivers: ftp site

To Install

CTRL + ALT + F1 to switch to TTY1 and login

sudo service gdm stop

To stop the X server

sudo su

To run as root

cd ~/Downloads

To install the 32bit driver (equiv for 64bit) then reboot.

To uninstall

sudo sh NVIDIA* --uninstall

Also remove /etc/X11/xorg.conf


If you run classic Ubuntu with effects do you get the same freeze issues as standard Ubuntu? If you cannot reproduce the freeze with classic Ubuntu (no effects) then this will point you towards a compiz issue. I would raise a launchpad bug report with the compiz team.

If space is available (e.g. 20Gb), you could dual boot/install alongside the latest oneiric alpha. Obviously this will itself be unstable, but it will come with the latest X and Kernel. You may need to also install manually the beta 280 graphics drivers above since it probably will not be offered in the Additional Drivers window.

If during testing you dont see the same freeze activity you could try uplifting your X version with the x-edgers ppa and using kernel kernel 3.0 in Natty. Going this route is not really desirable - and could cause you upgrade issues in the future - and may have other unforeseen stability issue. Again, use ppa-purge to remove the PPA.

Kernel 3.0 is packaged with the PPA - you'll need to install the headers as well as the kernel itself from synaptic BEFORE rebooting if you intend to install the nvidia drive later.

This is a testing ppa - do have a ready backup if you want to try this route.

share|improve this answer

On of the solutions I found that stopped my computer from freezing was to stop the cpu scheduler setting its self to ondemand. This is found in the /etc/init.d/ondemand script.

I just renamed the file.

sudo mv /etc/init.d/ondemand /etc/init.d/ondemand.bk

This breaks all the symbolic links to ondemand. So it won't start up at boot time. This will put some error messages into your log.

A better way is to use update-rc.d. I was lasy and have not tried these commands.

sudo update-rc.d -f ondemand remove  


sudo update-rc.d ondemand stop 2 3 4 5 S

To start it again:

sudo update-rc.d ondemand Start 2 3 4 5 S  

Although starting it again caused my computer to free again. So I left it disabled.

share|improve this answer

Also, sometimes it's simply the X-Server which hangs - a case I've most often found when you're using Compiz.

If this is the case you can kill X, which will restart and drop you back at the log-in screen.

The default sequence is Ctrl + Alt + Backspace

Although this is turned off by default (presumably new-users were accidentally hitting it) and can be turned back on like this:

  1. SystemKeyboard (i.e. the Keyboard Preferences Dialogue)
  2. Layouts tab
  3. Click the Options button
  4. At the Key Sequence to kill the X server point check Ctrl + Alt + Backspace.
share|improve this answer
If your video driver is using kernel modesetting (KMS), it's unlikely this will be sufficient to fix lockups, you have to use sysrq or power cycle. (Go ahead and try C-A-B, it obviously can't hurt; it does work when an app (like compiz/unity) is stuck, rather than X itself, however other answers on this page would be better in this case). But when it doesn't work, now you know why. :-) – Bryce Jun 16 '12 at 0:53

You might get some extra information when you switch to the TTY view. Press Ctrl + Alt + F1 to get this, use Ctrl + Alt + F7 (or maybe F8) to get back to the GUI. You can have different sessions on most of the F-keys but that's different question altogether.

share|improve this answer

The first thing to look at is if it is just X that's frozen, or the whole system. Enable ssh and then ssh into the system. If you can't ssh into it, then it's probably a kernel lock up. If you can ssh in, then it might be just a gpu lockup.

Next try restarting X. Do this by restarting the display manager:

  • On Ubuntu 11.10 and later, LightDM is the display manager, so run:

    service lightdm restart
  • On Ubuntu 11.04 and earlier, GDM is the display manager, so run:

    service gdm restart

If that works, then it's perhaps an X bug. If it still doesn't work, then you may have a GPU lockup in the kernel drm driver. It would be useful to know at this point whether you're running the -ati (open source) driver, or -fglrx (closed source) driver.

share|improve this answer

In such cases you can try CTRL-ALT-F1 to get to a console. Then login with your password.

Restarting the GUI

You can try to restart your graphical desktop with:

sudo service lightdm restart

If you're running Ubuntu 11.04 or earlier, you should use this instead (as gdm used to be the default display manager):

sudo service gdm restart

If you're using Kubuntu instead, then the default display manager is kdm, so you should instead use:

sudo service kdm restart

If you're using another display manager, replace ligthdm/gdm/kdm with its name.

Restarting the Machine

If you want to do a clean system reboot, use:

sudo shutdown -r now
share|improve this answer

My first favourite when total freeze occured - Alt + SysRq + K.

That combo kills X, and returns me to the graphical login screen. If that doesn't work, try Alt + SysRq + R E I S U B.

share|improve this answer

If you're getting a lot of freezes, there might be something wrong with your hardware. I used to get hard lockups every 48 hours due to some less than optimal RAM. Memtest86+ showed the fault after 40 minutes of testing. Swapped the RAM out for some more (under warranty) and I'm now at 32 days, 1 hour of uptime.

Ubuntu doesn't tend to leak its guts all over your memory like Windows can over time. Even if one application or a poor X video driver does, you can restart LigthtDM very simply and just keep going and going and going. I've actually been through three beta versions of the nvidia driver in this one boot :)

Anyway... While knowing how to restart softly is a very handy thing, finding, reporting and fixing the system should be your next priority. If it's an always-on system, you should easily be able to make it between kernel updates* without needing a restart.

*You should restart when you get kernel updates as they'll be security fixes that won't be applied until you reboot into the newer kernel.

share|improve this answer

In the very specific case you are using Virtualbox to run a 64-bit guest on a 32-bit (Ubuntu) host using VT-x or AMD-V (hardware virtualization technology built-in your CPU) only

Virtualbox may make your 32-bit host randomly crash when you run a 64-bit guest on it using VT-x or AMD-V (hardware virtualization technology built-in your CPU). It is a known issue.

2 solutions:

  1. You have to run 32-bit guests only on your current 32-bit host [recommended if you have less than 2 GB of RAM];
  2. You have to switch to Ubuntu 64-bit as host (you can even perform a 32-bit to 64-bit "migration" by reinstalling Ubuntu 64-bit without touching to your "/home" folder) [recommended if you have 2 GB of RAM or more].

Please note that you can run 64-bit and 32-bit guests on a 64-bit host using Virtualbox without any problem.

Other answers have very well covered general cases...

share|improve this answer

(Community wiki answer - solution was originally buried in the OP question)


Solved it.

My particular problem was my graphics card (integrated Radeon 9000 series). netconsole revealed I was getting the error: "reserve failed for wait". After trial-and-error, I manually configured my video card and disabled hardware acceleration. Completely fixed the issue.

Here is what I did:

Manually Created xorg.conf

Ubuntu automatically configures xorg.conf and doesn't use a file. To edit this file, you have to tell Ubuntu to explicitly create one and then edit it. Here are the steps:

  1. Restart system
  2. Hold Shift as GRUB boots
  3. Select root terminal in GRUB login menu
  4. Execute: X -config
  5. Copy: cp /etc/X11/xorg.conf

Disable Hardware Acceleration

The following is specific to my Radeon card, but I'm sure other cards have a similar setup.

  1. Edit xorg.conf
  2. Find "Device" section for graphics card
  3. Uncomment "NoAccel" option and set to "True"
  4. Save + reboot

Hope that helps.

share|improve this answer

Just press Ctrl+Alt+F1 on your keyboard to open TTY1. When it opens, run the Kill command. Example below.

first you use: ps this will show you all processes running ("ps | less" if you want to see the results page by page) Then you look for the PID of the process you want to terminate. After this use: kill pid

kill command- Stop a process from running

Syntax: kill [-s sigspec] [-n signum] [-sigspec] jobspec or pid kill -l [exit_status]

Description: Most modern shells, Bash included, have a built-in kill function. In Bash, both signal names and numbers are

accepted as options, and arguments may be job or process IDs. An exit status can be reported using the -l option: zero when at least one signal was successfully sent, non-zero if an error occurred. Using the kill command from /usr/bin, your system might enable extra options, such as the ability to kill processes from other than your own user ID and specifying processes by name, like with pgrep and pkill. Both kill commands send the TERM signal if none is given.



share|improve this answer

Hit Alt+F2 to run a command. Type xkill and hit Enter.

Your mouse cursor will transform into a cross that can force to close any window you click on.

If somebody can provide a screenshot, I think that would be useful.

share|improve this answer

Go to the dash,Enter System Monitor

In the System Manager go to the Processes tab,select the process,rightclick,Kill Process

Open Dash > Search System Monitor > Processes tab > Select the process > Right-Click >Kill Process

share|improve this answer
When system freezes..this option doesn't works – Rohit Bansal Jun 12 '12 at 6:22

You can always do Alt + F2 and write killall <program> or xkill and click on the window you want smashed!

share|improve this answer

The simplest solution is to add the "Force Quit" applet to your Gnome top panel and when a program doesn't respond, click on the force quit and then on the application.

I am surprised with so many answers, this isn't mentioned. Of course, you can always do a ps -A and pipe that to grep for your program name. And kill -9 that. I prefer simplicity.

share|improve this answer

I thinks there is no such thing as a perfect distro, even in Windows they have this screen of death.

  • Open another terminal Ctrl + Alt + F2.

  • Login with your username and password.

  • Issue this command:

    sudo /etc/init.d/gdm restart

    This restarts or logs you out of your current session but it will not reboot.

Then Ctrl + Alt + F7 go get back to your graphical interface.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.