Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All operating systems freeze sometimes, and Ubuntu is no exception. What should I do to regain control when...

  • just one program stops responding?
  • nothing at all responds to mouse clicks or key presses?
  • the mouse stops moving entirely?

In what order should I try various solutions before deciding to pull the power plug?

What should I do when starting up Ubuntu fails? Is there a diagnostic procedure I can follow?

share|improve this question
add comment

41 Answers

up vote 166 down vote accepted

When a single program stops working:

When a program window stops responding, you can usually stop it by clicking the X-shaped close button at the top left of the window. That will generally result in a dialog box saying that the program is not responding (but you already knew that) and presenting you with the option to kill the program or to continue to wait for it to respond.

Sometimes this does not work as expected. If you can't close a window by normal means, you can hit Alt+F2, type xkill, and press Enter. Your mouse cursor will then turn into an X. Hover over the offending window and left-click to kill it. Right clicking will cancel and return your mouse to normal.

If your program is running from a terminal, on the other hand, you can usually halt it with Ctrl+C. If not, find the name and process ID of its command, and end it with kill [process ID here]. If that fails despite waiting a few seconds, try sending a SIGHUP: kill -HUP [process ID here]. If all else fails, as a last resort send SIGKILL (-9): kill -9 [process ID here]. Note that you should only use SIGKILL as a last resort, because the process will be terminated immediately with no opportunity for cleanup.

When the mouse stops working:

If the keyboard still works, press Alt+F2 and run gnome-terminal (or, if these fail to launch, press Alt+Ctrl+F1 and login with your username and password). From there you can troubleshoot things. I'm not going to get into mouse troubleshooting here, as I haven't researched it. If you just want to try restarting the GUI, run sudo service lightdm restart. This should bring down the GUI, which will then attempt to respawn, bringing you back to the login screen.

When everything, keys and mouse and all, stop working:

First try the Magic SysReq method outlined in Phoenix' answer. If that doesn't work, press the Reset button on the computer case. If even that doesn't work, you'll just have to power-cycle the machine.
May you never reach this point.

share|improve this answer
7  
I've recently discovered that, rather than the "ps $options | grep $process_name" referenced above, one can just enter "pgrep $process_name" to achieve approximately the same result (for certain values of $options). –  koanhead Jun 4 '11 at 13:45
show 4 more comments

If it locks up completely, you can REISUB it, which is a safer alternative to just cold rebooting the computer.

REISUB by:

While holding Alt and the SysReq (Print Screen) keys, type REISUB.

R:  Switch to XLATE mode
E:  Send Terminate signal to all processes except for init
I:  Send Kill signal to all processes except for init
S:  Sync all mounted file-systems
U:  Remount file-systems as read-only
B:  Reboot

REISUB is BUSIER backwards, as in "The System is busier than it should be", if you need to remember it. Or mnemonically - R eboot; E ven; I f; S ystem; U tterly; B roken.

This is the SysReq key:

enter image description here


More info on all the Alt+SysReq functions here.

share|improve this answer
48  
In the event you're forced to do this, do it slowly. Let a few seconds pass in between each keypress so that the commands you're invoking have a chance to finish before you go to the next one. –  Amazed Apr 24 '11 at 8:22
12  
In case you like mnemonics: Raising Elephants Is So Utterly Boring, or Reboot Event If System Utterly Broken. I've also seen it as RSEIUB (Raising Skinny Elephants is Utterly Boring). –  Siegfried Gevatter Apr 26 '11 at 14:19
8  
I actually came up with this one and try to remember it this way: "Reset System Environment In UBuntu". or "Reset Environment In System UBuntu". –  Luis Alvarado Aug 14 '12 at 21:32
3  
What do you do if you're using a Mac that has no SysRq key? –  Cerin Jan 9 '13 at 23:22
5  
show 4 more comments

You can make the shortcut Ctrl+Alt+Delete open the System Monitor, with which you can kill any unresponsive applications.

  1. Open up System ➜ Preferences ➜ Keyboard Shortcuts and click Add.
    In the Command field, enter gnome-system-monitor. Name the shortcut whatever you want.

    enter image description here

  2. Click Apply and then click where it says Disabled. Now hit the keys Ctrl+Alt+Delete

    enter image description here

  3. Close Keyboard Shortcuts and try out the shortcut:

    enter image description here

share|improve this answer
1  
but if X is locking up fully, or even the kernel is hung, you can't do much with a keyboard shortcut. –  hexafraction Jun 14 '12 at 21:58
4  
Unfortunately, System Monitor is quite CPU intensive. It typically consumes up to 20% of my CPU, so if you're computer's bogged down, launching SM is only going to grind it into the dirt faster. –  Cerin Jan 9 '13 at 23:25
1  
If you can open System Monitor you can get to a terminal, in which case your OS is not frozen. –  nbm Nov 11 '13 at 23:32
show 1 more comment

If you're getting a lot of freezes, there might be something wrong with your hardware. I used to get hard lockups every 48 hours due to some less than optimal RAM. Memtest86+ showed the fault after 40 minutes of testing. Swapped the RAM out for some more (under warranty) and I'm now at 32 days, 1 hour of uptime.

Ubuntu doesn't tend to leak its guts all over your memory like Windows can over time. Even if one application or a poor X video driver does, you can restart LigthtDM very simply and just keep going and going and going. I've actually been through three beta versions of the nvidia driver in this one boot :)

Anyway... While knowing how to restart softly is a very handy thing, finding, reporting and fixing the system should be your next priority. If it's an always-on system, you should easily be able to make it between kernel updates* without needing a restart.

*You should restart when you get kernel updates as they'll be security fixes that won't be applied until you reboot into the newer kernel.

share|improve this answer
show 1 more comment

When everything stops working, first try Ctrl + Alt + F1 to go to a terminal, where you can likely kill X or other problem processes.

If even that doesn't work, try using holding down Alt + SysReq while pressing (slowly, with a few seconds between each) R E I S U B.

This puts the keyboard in raw mode, ends tasks in various states, syncs the disks, etc, and finally reboots the machine. You will get much better results doing this than just pulling the plug. Of course, if this fails, you're pretty much left with pulling the plug.

share|improve this answer
7  
A way to remember "REISUB" is "Reboot Even If System Utterly Broken". –  Matthew Crumley Sep 20 '10 at 3:15
4  
or "Raising Elephants Is So Utterly Boring" :P –  Axel Sep 20 '10 at 12:09
4  
I remember it using "BUSIER" Backwards –  Nerdfest Sep 20 '10 at 16:33
3  
Between Ctrl+Alt+F1 and trying to kill processes, and Alt+SysRq+R E I S U B, it's worth pressying Ctrl+Alt+Delete. If you successfully got to a text-based virtual console (from having pressed Ctrl+Alt+F1), this will virtually always reboot the machine. –  Eliah Kagan Jun 14 '12 at 21:24
show 1 more comment

Also, sometimes it's simply the X-Server which hangs - a case I've most often found when you're using Compiz.

If this is the case you can kill X, which will restart and drop you back at the log-in screen.

The default sequence is Ctrl + Alt + Backspace

Although this is turned off by default (presumably new-users were accidentally hitting it) and can be turned back on like this:

  1. SystemKeyboard (i.e. the Keyboard Preferences Dialogue)
  2. Layouts tab
  3. Click the Options button
  4. At the Key Sequence to kill the X server point check Ctrl + Alt + Backspace.
share|improve this answer
2  
If your video driver is using kernel modesetting (KMS), it's unlikely this will be sufficient to fix lockups, you have to use sysrq or power cycle. (Go ahead and try C-A-B, it obviously can't hurt; it does work when an app (like compiz/unity) is stuck, rather than X itself, however other answers on this page would be better in this case). But when it doesn't work, now you know why. :-) –  Bryce Jun 16 '12 at 0:53
show 1 more comment

My first favourite when total freeze occured - Alt + SysRq + K.

That combo kills X, and returns me to the graphical login screen. If that doesn't work, try Alt + SysRq + R E I S U B.

share|improve this answer
add comment

Freezes such as you have described can be both software and hardware related and as you have found sometimes frustratingly difficult to diagnose.

Hardware

If this is a desktop PC look at your hardware-cards. For both laptops and desktops possibly acpi type issues.

It might be useful to temporarily simplify your configuration to have just the graphics card connected with a standard keyboard and mouse. All other cards should be removed.

For acpi related issues, try booting with noapic nomodeset in your grub boot option. Its also worth trying acpi=off although this could have other undesirable effects such as constant fan usage.

Also worth checking the bios version level and seeing if the vendor has a newer bios version. The readme notes should hopefully reveal if any newer version fixed crashes and freezes.

Software

I note you have tried the standard 270 drivers but have failed due to freezes. Can you clarify if you had similar issues with the open-source driver? Obviously you will not get Unity during testing this.

Graphics freezing can be one of/or a combination of the driver/compiz/X/kernel

If you are willing to try any of the suggestions below first backup your system with a good backup tool such as CloneZilla. You will need an external media device to receive the image such as a large USB stick/drive or separate internal hard-drive.

Installing newer nVidia driver

Deactivate (uninstall) your current 173-nvidia driver using the Additional Drivers window.

There are a small number of important fixes primarily in the 275 stable but a small number also in the 280beta that fixed freezes - it is worth a shot to see if these apply to your graphics card. Unfortunately nvidia dont go into detail on which cards they specifically fix (readme.txt)

However - I would strongly recommend a backup unless you feel confident on reversing a nvidia install - especially since you had serious issues with the slightly older 270 drivers. I've used clonezilla countless times and it has always got me out of trouble. You do need a large external drive though - USB stick/external drive or a separate drive.

X Updates

The latest graphics drivers have been packaged in the x updates ppa.

Note - this will lead you away from the standard baseline - if upgrading in the future ppa-purge the PPA itself before upgrading.

You can also manually install the drivers from nVidia:

Try installing the latest nvidia stable 275 or 280 drivers - 32bit 280 drivers: ftp site and 64bit: 280 drivers: ftp site

To Install

CTRL + ALT + F1 to switch to TTY1 and login

sudo service gdm stop

To stop the X server

sudo su

To run as root

cd ~/Downloads
sh NVIDIA-Linux-x86-280.04.run

To install the 32bit driver (equiv for 64bit) then reboot.

To uninstall

sudo sh NVIDIA* --uninstall

Also remove /etc/X11/xorg.conf

X/Kernel/Compiz

If you run classic Ubuntu with effects do you get the same freeze issues as standard Ubuntu? If you cannot reproduce the freeze with classic Ubuntu (no effects) then this will point you towards a compiz issue. I would raise a launchpad bug report with the compiz team.

If space is available (e.g. 20Gb), you could dual boot/install alongside the latest oneiric alpha. Obviously this will itself be unstable, but it will come with the latest X and Kernel. You may need to also install manually the beta 280 graphics drivers above since it probably will not be offered in the Additional Drivers window.

If during testing you dont see the same freeze activity you could try uplifting your X version with the x-edgers ppa and using kernel kernel 3.0 in Natty. Going this route is not really desirable - and could cause you upgrade issues in the future - and may have other unforeseen stability issue. Again, use ppa-purge to remove the PPA.

Kernel 3.0 is packaged with the PPA - you'll need to install the headers as well as the kernel itself from synaptic BEFORE rebooting if you intend to install the nvidia drive later.

This is a testing ppa - do have a ready backup if you want to try this route.

share|improve this answer
show 5 more comments

DoR and Phoenix has answered this well. To make this page more complete I would add:

If it is only X that is "broken", than you can use kernel to kill it:

SysRq + Alt + K

For laptops (depends on the model, typically needed if "SysRq" is written in blue):

Fn + SysRq + Alt + K (release Fn after pressing SysRq).

share|improve this answer
show 2 more comments

What I do is opening a terminal with eg. Ctrl + Alt + F2

Login and use the terminal to kill the process that is lagging

ps -e | grep <procesname>

This shows the processID of the process with that name

(sudo) kill <processID>

This shuts down the process safely, in case that doesn't work use

(sudo) kill -9 <processID>

Use the man pages for more information about these commands.

You can get back to the graphical user interface with Ctrl + Alt + F7

share|improve this answer
8  
ps and grep PROCESS can be replaced by a pgrep PROCESS call, and your whole thing can simply be replaced by pkill PROCESS or a killall PROCESS. –  queueoverflow Apr 24 '11 at 22:01
show 2 more comments

In such cases you can try CTRL-ALT-F1 to get to a console. Then login with your password.

Restarting the GUI

You can try to restart your graphical desktop with:

sudo service lightdm restart

If you're running Ubuntu 11.04 or earlier, you should use this instead (as gdm used to be the default display manager):

sudo service gdm restart

If you're using Kubuntu instead, then the default display manager is kdm, so you should instead use:

sudo service kdm restart

If you're using another display manager, replace ligthdm/gdm/kdm with its name.

Restarting the Machine

If you want to do a clean system reboot, use:

sudo shutdown -r now
share|improve this answer
add comment

To diagnose the freezes you should be able to use the net console (or serial serial console for that matter). Follow the set up instructions outlined here.

share|improve this answer
show 2 more comments

The first thing to look at is if it is just X that's frozen, or the whole system. Enable ssh and then ssh into the system. If you can't ssh into it, then it's probably a kernel lock up. If you can ssh in, then it might be just a gpu lockup.

Next try restarting X. Do this by restarting the display manager:

  • On Ubuntu 11.10 and later, LightDM is the display manager, so run:

    service lightdm restart
    
  • On Ubuntu 11.04 and earlier, GDM is the display manager, so run:

    service gdm restart
    

If that works, then it's perhaps an X bug. If it still doesn't work, then you may have a GPU lockup in the kernel drm driver. It would be useful to know at this point whether you're running the -ati (open source) driver, or -fglrx (closed source) driver.

share|improve this answer
show 5 more comments

If you have to do a hard shutdown I'd be wondering if the memory (RAM) was failing. On your next boot, try running memtest86. To do this:

  • while booting, hold down a shift key
  • the GRUB menu will appear
  • use the cursor keys to select the last option "memtest86"
  • press enter

You'll get a basic display and it will try reading and writing lots of values to all of your RAM. As long as there are no failures, you'll see a green status. If there is any failure it will turn red. In that case you'll need to replace at least one stick of your RAM.

There is also community documentation of diagnosing hardware failures.

share|improve this answer
add comment

If you ever use the magic SysRq key as suggested in the first answer, just try getting the keyboard to work first with Alt + SysRq + R; then try Ctrl + Alt + F1 again.

It may work and you may save yourself a reboot. Only if it doesn't work you should try the whole REISUB sequence.

share|improve this answer
add comment

Just press Ctrl+Alt+F1 on your keyboard to open TTY1. When it opens, run the Kill command. Example below.

first you use: ps this will show you all processes running ("ps | less" if you want to see the results page by page) Then you look for the PID of the process you want to terminate. After this use: kill pid

kill command- Stop a process from running

Syntax: kill [-s sigspec] [-n signum] [-sigspec] jobspec or pid kill -l [exit_status]

Description: Most modern shells, Bash included, have a built-in kill function. In Bash, both signal names and numbers are

accepted as options, and arguments may be job or process IDs. An exit status can be reported using the -l option: zero when at least one signal was successfully sent, non-zero if an error occurred. Using the kill command from /usr/bin, your system might enable extra options, such as the ability to kill processes from other than your own user ID and specifying processes by name, like with pgrep and pkill. Both kill commands send the TERM signal if none is given.

Source: http://www.linuxforums.org/forum/newbie/53976-end-tasks-linux-like-task-manager-windows.html

Source: http://webtools.live2support.com/linux/kill.php

share|improve this answer
show 5 more comments

I thinks there is no such thing as a perfect distro, even in Windows they have this screen of death.

  • Open another terminal Ctrl + Alt + F2.

  • Login with your username and password.

  • Issue this command:

    sudo /etc/init.d/gdm restart
    

    This restarts or logs you out of your current session but it will not reboot.

Then Ctrl + Alt + F7 go get back to your graphical interface.

share|improve this answer
add comment

The simplest solution is to add the "Force Quit" applet to your Gnome top panel and when a program doesn't respond, click on the force quit and then on the application.

I am surprised with so many answers, this isn't mentioned. Of course, you can always do a ps -A and pipe that to grep for your program name. And kill -9 that. I prefer simplicity.

share|improve this answer
show 1 more comment

You can always do Alt + F2 and write killall <program> or xkill and click on the window you want smashed!

share|improve this answer
add comment

(Community wiki answer - solution was originally buried in the OP question)

SOLUTION:

Solved it.

My particular problem was my graphics card (integrated Radeon 9000 series). netconsole revealed I was getting the error: "reserve failed for wait". After trial-and-error, I manually configured my video card and disabled hardware acceleration. Completely fixed the issue.

Here is what I did:

Manually Created xorg.conf

Ubuntu automatically configures xorg.conf and doesn't use a file. To edit this file, you have to tell Ubuntu to explicitly create one and then edit it. Here are the steps:

  1. Restart system
  2. Hold Shift as GRUB boots
  3. Select root terminal in GRUB login menu
  4. Execute: X -config xorg.conf.new
  5. Copy: cp xorg.conf.new /etc/X11/xorg.conf

Disable Hardware Acceleration

The following is specific to my Radeon card, but I'm sure other cards have a similar setup.

  1. Edit xorg.conf
  2. Find "Device" section for graphics card
  3. Uncomment "NoAccel" option and set to "True"
  4. Save + reboot

Hope that helps.

share|improve this answer
add comment

Replace with the latest Linux kernel 2.6.35 or up that will solve your problem. Follow these steps from this link http://www.ramoonus.nl/2010/05/linux-kernel-2-6-34-installation-guide-for-ubuntu-linux-10-04/

share|improve this answer
show 2 more comments

if possible, try to open an ssh shell from another computer. this is an option If you knew in advance that the computer might hang soon, open the connection first before you perform that task.

I do this sometimes when I know vmware runs crazy and the GUI of ubuntu (the vmware host) becomes unresponsive. I can do a suspend from the ssh shell, it might take a while until it gets thru, and after a while the computer is idle again.

share|improve this answer
show 3 more comments

In the very specific case you are using Virtualbox to run a 64-bit guest on a 32-bit (Ubuntu) host using VT-x or AMD-V (hardware virtualization technology built-in your CPU) only

Virtualbox may make your 32-bit host randomly crash when you run a 64-bit guest on it using VT-x or AMD-V (hardware virtualization technology built-in your CPU). It is a known issue.

2 solutions:

  1. You have to run 32-bit guests only on your current 32-bit host [recommended if you have less than 2 GB of RAM];
  2. You have to switch to Ubuntu 64-bit as host (you can even perform a 32-bit to 64-bit "migration" by reinstalling Ubuntu 64-bit without touching to your "/home" folder) [recommended if you have 2 GB of RAM or more].

Please note that you can run 64-bit and 32-bit guests on a 64-bit host using Virtualbox without any problem.

Other answers have very well covered general cases...

share|improve this answer
add comment

You might get some extra information when you switch to the TTY view. Press Ctrl + Alt + F1 to get this, use Ctrl + Alt + F7 (or maybe F8) to get back to the GUI. You can have different sessions on most of the F-keys but that's different question altogether.

share|improve this answer
show 1 more comment

On of the solutions I found that stopped my computer from freezing was to stop the cpu scheduler setting its self to ondemand. This is found in the /etc/init.d/ondemand script.

I just renamed the file.

sudo mv /etc/init.d/ondemand /etc/init.d/ondemand.bk

This breaks all the symbolic links to ondemand. So it won't start up at boot time. This will put some error messages into your log.

A better way is to use update-rc.d. I was lasy and have not tried these commands.

sudo update-rc.d -f ondemand remove  

Or:

sudo update-rc.d ondemand stop 2 3 4 5 S

To start it again:

sudo update-rc.d ondemand Start 2 3 4 5 S  

Although starting it again caused my computer to free again. So I left it disabled.

share|improve this answer
show 2 more comments

I was having similar issues with 10.04. X would hang and and nothing but a reset would fix it. I updated my nvidia drivers to the latest version and I haven't had issues since.

share|improve this answer
show 1 more comment

If you are using motherboard of intel 8xx, then I would strongly recommend to migrate to Ubuntu 10.10 Maverick Meerkat, I think they have solved the Xorg related bugs.

I had faced the same problems but once I installed Ubuntu 10.10 Maverick Meerkat, I have never faced any Xfreeze issue.

share|improve this answer
add comment

It's very likely a problem with opengl graphics acceleration. I have the same problem on my kubuntu 11.04 machine. When I disable desktop effects completely, the problem disappears.

share|improve this answer
show 1 more comment

Go to the dash,Enter System Monitor

In the System Manager go to the Processes tab,select the process,rightclick,Kill Process

Open Dash > Search System Monitor > Processes tab > Select the process > Right-Click >Kill Process

share|improve this answer
3  
When system freezes..this option doesn't works –  Rohit Bansal Jun 12 '12 at 6:22
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.