Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to install Ubuntu on my Acer Extensa 5420 laptop. At the point where Gparted should allow me to select partitions I could not see my Windows partitions with Vista and XP installed on them. It was written that the disk has no operating systems installed.

After googling I found out that this behavior may be caused by SATA drive with suggestions to change settings in BIOS. My BIOS does not provide means to change such settings. Has anyone here encountered the similar problem? Any suggestions how to install ubuntu? I have two partitions on my HDD and about 35GB of unallocated space.

share|improve this question
It certainly has nothing to do with the drive being SATA and ACHI is the preferred mode, but it doesn't make much difference. Run sudo parted -l and see what it says. – psusi May 20 '11 at 14:48
It gave me an Error: /dev/sda: urecognised disk label (that's the disk with windows), and correctly recognized ubuntu live usb drive. – bancer May 20 '11 at 16:30
The first partition under Vista has no label (9.77GB). Probably, that's the partition with Vista image to restore factory settings. May this be the cause of the problem? – bancer May 20 '11 at 17:06
Different kind of label. By label, parted means the partition table. It thinks you don't have a valid partition table. See what sudo fdisk -lu /dev/sda thinks. – psusi May 20 '11 at 19:09
sudo fdisk -lu /dev/sda returned nothing but prompt for the next command. By the way, when I boot Ununtu Live in "try" mode and run Gparted it sees only the drive with Live USB. It does not see sda drive. – bancer May 20 '11 at 19:27
up vote 1 down vote accepted

Before you begin I recommend understanding what a partition is and the tools available under linux. is a very good resource.. I expect the problem is related to a partition type being marked as type hidden.

You could use to gdisk(gpt-fdisk) get information on your paritions. I would get the latest version, I think that is 0.7. The creator of the tool has excellent documentation on how disk partion structures and information is set up and can be changed. I recently changed a disk structure I had created as gpt to mbr to fix a problem with windows not wanting to install on a disk. gdisk could probably fix your problem by recreating the mbr in a format that would make it accessible to your Linux system.

Testdisk should be installed as well. Testdisk is one of the best tools for fixing partition problems and I have used it numerous times. This might be simpler to use, but it is not as informative as to what is going on with your actual disk structures. I would use gdisk to find out what is going on and then use testdisk to see if you can make the changes that allow you to resize your partitions.

You can change your disk partition labels with fdisk and parted as well. The first step is to get the actual structure of your disk and make a back up. So that you can fix problems, and later go back if you need to. Use dd or diskdump command explained here at the bottom of the page.

Microsoft has this documentation that might help

I have found this problem with windows 7 and vista pre-installed on certain computers. My solution was to format the drives under Linux and reinstall MSwin afterwards. In one case I removed the hard drive put it into an external casing because Linux could not even see the drive to format it. I believe the bios was protecting the hard drive. Some thing the manufactures set up to prevent people making changes.

I expect your are not afraid to read. There is no short answer to your problem with out more specific information. I hope this will get you up to a point where you understand the problem and what tools you have to solve it. If you need help with a specific problem / tool post back and update your question.

share|improve this answer
+1 for extensive answer. – bancer Jun 1 '11 at 21:06

Often the cause of this is rooted in windows. Boot to XP - go to my computer - right click C Drive - go to properties - find check drive for errors (I am working on memory as I only have Ubuntu on my system) - there will be two boxes to tick - tick the top box only - tell the computer to fix errors - It cannot, so it will ask you to do it on next boot - agree and reboot. You should get a dos environment and it will perform three checks (Five if you ticked both boxes AND take a long time). After this use your live CD and go to gparted. You should see your drives now. You MAY need to repeat this on all your drives. Good luck - Mal

share|improve this answer
I performed the check disk on every partition under Vista with 'fix errors' option. But unfortunately that has not resolved the problem. – bancer May 20 '11 at 16:14

I'm going with an unsupported HD controller. Install with wubi or in a VM. Alternately, you could see if there is some tweaking required for your controller. I know some mac's have a particular nvidia chipset that doesn't work properly with debian/ubuntu until edge(or whatever it's called in this distro).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.