Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi there I have an ntfs partition which is mounted automatically on ubuntu's startup.

In qBittorrent I have the default download folder is that ntfs partition, but after I mount the partition automatically, I always have this message when I run qBittorrent :

An I/O error occured for torrent XXX Error: permission denied.

I tried to unmount the ntfs partition but I get that the authentication is required to unmount it, so I think the partition is mounted by the root user.

In the /etc/fstab file, this is the line which auto-mount the ntfs partition :

UUID=32EA23CFEA238DE3 /media/Backup ntfs rw,auto,users,exec,nls=utf8,umask=003,gid=46,uid=1000    0   0

So, I think if the partition was mounted as me, I won't see this error message.

In the other hand, I tried to run qBittorrent as the root user, but I'm not seeing any of my downloads in the it.

how can I solve this problem ?

share|improve this question

1 Answer 1

You are using the wrong options for your ntfs partition in /etc/fstab Some of the options you use, such as "rw" and "exec" are invalid when mounting a ntfs partition.

If you read the man page for mount - http://linux.die.net/man/8/mount you will see the options.

I know it is a long page, scroll down to the ntfs section.

You want to mount the ntfs partition with ntfs-3g, not ntfs http://www.tuxera.com/community/ntfs-3g-download/

The options for ntfs (ntfs-3g) are here: http://linux.die.net/man/8/mount.ntfs-3g

I suggest you use

UUID=32EA23CFEA238DE3 /media/Backup ntfs-3g auto,users,permissions,nls=utf8  0 0

you can then set ownership and permissions using chown and chmod

If that does not work, you can set ownership and permissions

UUID=32EA23CFEA238DE3 /media/Backup ntfs auto,users,nls=utf8,umask=003,gid=46,uid=1000 0 0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.