Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am configuring an custom built server with Intel Server Board 1200v3RPS. I have installed Ubuntu 12.04 Desktop amd64 as the OS. Issue that I am facing in this is, On-board Network has not been installed by default.

I did a quick search and found that not many people have installed Ubuntu on this Intel board.

Intel website gives drivers for Redhat & SUSE only. This is first time I am installing Ubuntu on Server platform. So far only worked with Redhat/CentOS.

Kindly let me know how to do I install network card drivers in Ubuntu 12.04.

Thanks in advance.

share|improve this question
add comment

2 Answers 2

Welcome to Ubuntu Linux

You may not actually need a brand/device 'driver', as Debian/Ubuntu have generic drivers for most mainstream hardware.

Unless you have a new chip/design, or specific high performance/availability requirements, the standard driver should suffice.

Gone and the bad old yesterdays (from RedHat/Fedora 4) of insert first CD (for OS install), then spend 20-40 minutes shuffling through discs 4 thru 9 for each brand/device driver. Ubuntu OS (and all drivers) has fit on a single 600MB CD until only quite recently.


Does this have / need a screen, keyboard, and graphic interface?

Otherwise you are better off using the Ubuntu 12.04 LTS server variant.


UPDATE:

Check (and or add to your question) output from dmesg | grep igb. I'm not sure if that is the correct ID for Intel Gigabit Ethernet driver for Ubuntu, but its sound right.

Look at How do I enable the "backports" repository? for Precise (12.04) back ports.

share|improve this answer
    
Hi, The reason I used desktop edition here is, Server would be used for connecting nComputing clients of L300 model with vSpace software installed. So i need GUI. I know I can install Server and then configure GUI on but i avoided the two steps. Secondly standard/generic driver should suffice my needs here. But strangely Ubuntu is not loading it :( –  SarveshM Mar 29 at 4:27
    
Your Intel Server board has dual Intel I210 PHY (low power) Ethernet cards/chips. This is the same problem: unix.stackexchange.com/questions/98417/… –  david6 Mar 29 at 4:54
    
Can you verify, with: lspci -nn | grep Eth ? –  david6 Mar 29 at 4:58
    
Yes as per m/b manual thats the dual NIC controller. I will reach office in couple of hours time and should be able to verify the command output. The stackexchange seems to give the solution need to check when I reach onsite. Thanks David. –  SarveshM Mar 29 at 5:20
    
Hi David, yes the the card is indeed Intel I210 PHY. as per the unixstack link, that was able to see the interface in ifconfig -a but in my case not able to get in ifconfig as well. Checking further. –  SarveshM Mar 29 at 10:13
add comment

The issue is resolved, i used the driver from CD as it had source files. I used the below link as reference.

Ubuntu 12.04 loses ethernet driver after update and reboot

Inside the folder of linux drivers in Intel CD. I did following and network got connected.

sudo make install

sudo modprobe igb

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.