Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Greetings I am running UBUNTU 12.04 and logging in on UBUNTU 3D. Wondering if anyone knows the definitive answer to getting xscreensaver to load at start-up? I have removed gnome screensaver, installed xscreensaver with no results.

I have tried adding start-up applications:

> xscreensaver –nosplash (with no results)

also executed:

sudo gedit /etc/xdg/autostart/screensaver.desktop

with is output:

> [Desktop Entry]
> Exec=xscreensaver
> Name=XScreenSaver
> Blockquote
> Type=Application
> X-KDE-StartupNotify=false

(with no results)

Also when I manually open the screensaver I get this error:

The XScreenSaver daemon doesn't seem to be running on ":0". Launch it now?

I have also tried following the instructions here (top answer)

Any help is appreciated.

share|improve this question
I'm not sure if it's a typo, but you have xscreensaver –nosplash not xscreensaver -nosplash. (It should be a hyphen, not an en-dash.) – Sparhawk Mar 28 '14 at 22:52
I didn't see that. Wondering though if that oversight would actually disable the launching at startup? I did try just entering the command without the splash part and ha no success. I believe the problem is rooted in the daemon error though – Kalamalka Kid Mar 29 '14 at 3:33
Ok, can you try testing that startup applications work (e.g. replace the xscreensaver command with something like date > /tmp/startup_script_out, and then check the file at /tmp/startup_script_out), and also check that the real command works (i.e. try manually running xscreensaver -nosplash in the terminal after startup). Also, you can test if xscreensaver is running with pgrep xscreensaver in the terminal. – Sparhawk Mar 29 '14 at 3:52
ok hang on. fixing somethign here – Kalamalka Kid Mar 29 '14 at 4:25
date > /tmp/startup_script_out was entered into start-up. But could see no such file in the /tmp/ folder. WHen I try to run the command xscreensaver I get the error: xscreensaver: 21:39:54: "gnome-screensaver" is already running on display :0.0 (window 0x2e00001) – Kalamalka Kid Mar 29 '14 at 4:40
up vote 0 down vote accepted

ok the answer is this: I had the WRONG directory for the applications. The path I had before was incorrect/. to determine which path was teh correct one i executed:


$ which xscreensaver


which pointed out this was the path:


I put that in the command line in the startup menu application and it worked!

share|improve this answer

In Xubuntu 14.04 I opened

sudo mousepad /etc/xdg/autostart/screensaver.desktop, 

and commented out the line


to read

# Exec=xscreensaver

saved the file and restarted my computer. Result: screen saver doesn't start at all.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.