Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to upgrade my wife's Packard Bell netbook running Lubuntu 12.04 LTS to 12.10. It all ran smoothly until after the downloading of packages and requesting I confirm that some will be removed, added etc.

When I returned after leaving it to do it's thing, I had a black screen with a lot of text which unfortunately I did not note down although it was very cryptic. I do remember that it was mentioning something about the kernel, although if this is the problem I don't know.

I had to hard reboot and tried the recovery mode. I managed to get to a root shell and noticed that it is not a problem of disk space. Before the upgrade there was over 3GB on /, and now there is about 2GB. What is strange though is that the /home does not get mounted automatically at bootup. I tried various schemes as reported below to get it mounted automatically without any success.

I then tried various options such as:

fsck dpkg network root grub system-summary = reports no /home directory

Each time it asks me to mount all the filesystem in fstab and when I confirm it stops at

mountall: mount /home/mywife/etc/etc/ terminated with status 1

it says such as in place of etc/etc/ Documents Music Media Pictures and so on. I tried to find the solution suggested in various forums including this one but with no exact situation like mine.

Help will be much appreciated.

The /etc/fstab below:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sda1       /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda5 during installation
UUID=b2c60910-ff66-4713-a629-37c293b62393 /home           ext4    defaults        0       2
#/dev/sda2       none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0
192.168.2.2:/home/ericam/Documents /home/ericam/media/Documents nfs timeo=14,intr,rsize=8192,wsize=8192 0 0
192.168.2.2:/home/ericam/Pictures /home/ericam/media/Pictures nfs timeo=14,intr,rsize=8192,wsize=8192 0 0
192.168.2.2:/home/ericam/Music /home/ericam/media/Music nfs timeo=14,intr,rsize=8192,wsize=8192 0 0

This does seem a bit strange.This is the 1st time I see the /cryptswap and mounting to the ../media/.. directory! There doesn't seem to be any older or backup fstab which would show up the differences.

running "df" as root brings up the following:

df: `/run/user': no such file or directory
Filesystem       1K-blocks ........ Use%    Mounted on
/dev/sda1        ..................  79%    /
udev             ..................   0%    /dev
none             ..................   1%    /run/lock
none             ..................   1%    /run/shm

I had to type it out so bear with the ..... bit.

Here is the output for the lsblk command:

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 232.9G  0 disk 
├─sda1   8:1    0   9.3G  0 part /
├─sda2   8:2    0   2.8G  0 part 
├─sda3   8:3    0     1K  0 part 
└─sda5   8:5    0 220.8G  0 part 
sdb      8:16   1   1.9G  0 disk 
└─sdb1   8:17   1   1.9G  0 part /mnt

Note that sdb is the usb stick I used to copy over the data. I might add that I used the mount command.

After a few days I tried the following:

The fstab was changed to this:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
#/dev/sda1       /               ext4    errors=remount-ro 0       1
UUID=d7ae9306-1dac-416e-8d59-1055ada63c48   /   ext4    errors=remount-ro 0       1
# /home was on /dev/sda5 during installation
#/dev/sda5  /home           ext4    defaults        0       2
UUID=b2c60910-ff66-4713-a629-37c293b62393 /home           ext4    defaults        0       2
/dev/sda2       none            swap    sw              0       2
#/dev/mapper/cryptswap1 none swap sw 0 0
#192.168.2.2:/home/ericam/Documents /home/ericam/media/Documents nfs timeo=14,intr,rsize=8192,wsize=8192 0 0
#192.168.2.2:/home/ericam/Pictures /home/ericam/media/Pictures nfs timeo=14,intr,rsize=8192,wsize=8192 0 0
#192.168.2.2:/home/ericam/Music /home/ericam/media/Music nfs timeo=14,intr,rsize=8192,wsize=8192 0 0

I have amended the fstab after this questions advice: my /home is not mounted after 12.04 upgrade I changed the lines to include the UUID which are correct. I checked... The command 'fdisk -l' shows:

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3e751ccc

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048    19531775     9764864   83  Linux
/dev/sda2       482537472   488396799     2929664   82  Linux swap / Solaris
/dev/sda3        19533822   482535423   231500801    5  Extended
/dev/sda5        19533824   482535423   231500800   83  Linux

Partition table entries are not in disk order

Disk /dev/sdb: 2002 MB, 2002780160 bytes
62 heads, 62 sectors/track, 1017 cylinders, total 3911680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0001dbd4

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          62     3909347     1954643    c  W95 FAT32 (LBA)

It still won't mount at bootup.....

share|improve this question
    
Are you able to post your /etc/fstab contents? –  Nattgew Mar 28 at 19:24
    
Added to the original above. –  Jacques MALAPRADE Mar 28 at 19:50
    
How about output from df in the root prompt, to check what has been mounted? –  Nattgew Mar 28 at 21:11
    
Added to above. –  Jacques MALAPRADE Mar 28 at 21:27
    
Do you think it is a problem with the fstab being corrupted? You would think that during an upgrade the previous fstab would be saved as a .old or something. –  Jacques MALAPRADE Mar 28 at 21:49

2 Answers 2

If you can get your /home to mount correctly, you should try to do a normal boot and finish the upgrade. If your sources.list has quantal, then do a regular update, otherwise run the upgrade again:

update-manager -d

Or, if you are unable to get to a graphical session, try from the command line:

sudo apt-get install update-manager-core
sudo do-release-upgrade -d

https://help.ubuntu.com/community/Upgrades

share|improve this answer
    
I commented out everything except the /dev/sda1 line (/) in fstab, uncommented the /dev/sda2 line (swap), and added a line for /dev/sda5 as suggested above. /dev/sda5 /home ext4 defaults 0 2 It still doesn't mount the /home directory. Any suggestions? – –  Jacques MALAPRADE Mar 29 at 8:55
    
I have managed to mount the /home directory. Quantal appears in the sources.list file. I would like to update but it says that not all the files have been downloaded. I tried to use the "with networking" option in the recovery menu but it needs to run fstab and then hangs. How to run sudo apt-get update; sudo apt-get upgrade with no internet connection? –  Jacques MALAPRADE Mar 30 at 20:13
    
Tried sudo apt-get install update-manager-core and it comes up with: W: Not using locking for read only lock file /var/lib/dpkg/lock E: dpkg was interupted, you must manually run 'dpkg --configure -a' to correct the problem. When I run it it says dpkg: error: unable to access dpkg status area: Read-only file system. Even with sudo I get the same. –  Jacques MALAPRADE Mar 30 at 20:20
    
Can you find an error from when it boots and fails to mount /home/? –  Nattgew Apr 2 at 14:49
    
A quick update on the errors at bootup: (1) Normal boot: Displays lubuntu splash and hangs. (2) FailsafeX graphics mode: Asks to continue mounting using /etc/fstab. As yes is only option, continues and hangs at fsck from util-linux 2.20.1 and /dev/sda1: clean, .... files .... blocks and /dev/sda5: clean, ..... (3) Root terminal: At prompt I mount /dev/sda5 /home which works, then fdisk -l shows all the partitions no problem but df -h there is no /dev/sda5` or home, but df: /run/user: No such file or directory... /run/rpc_pipefs:.. (4) Grub loader: fsck.../dev/sda... –  Jacques MALAPRADE Apr 2 at 20:03
up vote 0 down vote accepted

I have a way to get the /home directory to mount with instruction on this page: 13.10 won't start after upgrading I will recap for brevity what worked for me:

  1. Dropping to root shell in the options of the Recovery mode at bootup.

  2. Run

    mount -o remount,rw /
    
  3. Then

    mount --all
    
  4. Then

    dpkg --configure -a
    
  5. Then

    reboot
    
  6. After the reboot ran

    apt-get -f install
    
  7. Following this I ran the last step as described above:

    update-manager -d
    
share|improve this answer
    
Since it says 12.10 it seems like the upgrade worked at least partially. Did you try doing a normal update? –  Nattgew Apr 7 at 15:10
    
Thanks for your help Nattgew. I persisted and found the solution. I am struggling with the bluetooth now but that's another question. –  Jacques MALAPRADE Apr 7 at 15:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.