Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running 11.04 server, headless, and at a certain point it didn't boot anymore: it just stopped. It seems like I made a mistake with some of the disks, the fstab or the raid config, anycase one of the arrays couldn't be mounted.

What happens is that there is some fancy screen (too fancy for my old LCD, but that's another question) saying Couldn't mount /foobar. Press s to continue or [..].

What I want is that it continues automatically. If I reboot I should check if that worked, fine, but I don't want to guess what button to press for it to continue, and I certainly don't want to have to run it with some sort of screen. Obviously, if / fails to mount then moving on is kinda hard to do. Ok. I get it, but when some raid doesn't come up, I have to boot to fix it.

How can I have ubuntu server 11.04 skip all but the fatal errors?

share|improve this question
    
Please keep a review of the question and occasionally modify it with more information just so that the question pops to the top of the active list. –  fossfreedom Feb 23 '12 at 13:13
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  Mark Rooney Mar 23 '12 at 23:28
    
I'm not really sure what you're getting at. I could add fake and random information, but the question seems clear enough. I have neither a sollution, nor has the need for one gone away. –  Nanne Mar 24 '12 at 15:38
    
possible duplicate of How do I avoid the "S to Skip" message on boot? –  qbi Apr 7 '12 at 20:17
add comment

1 Answer

up vote 1 down vote accepted

After A LOT of looking around I came across a Ubuntu Forums question that should solve your issue;

Fixed it by editing /etc/fstab

Edit the line with the affected drive, and add the following option: nobootwait

/dev/sdax /media/drive auto rw,user,exec,nobootwait 0 0

Reference

This will obviously only work for drive mount errors not ALL errors, I'm not certain how you could ignore all errors regardless but I would think that you would want to know what the actual error is.

share|improve this answer
    
Nice one. It doesn't fix all boot problems, but it's a step closer, and probably as close as I'm going to get to fixing stuff like this, thanks :) –  Nanne Mar 25 '12 at 11:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.