Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried installing these driver using ever method that I could find. The first way I tried was to just download the drivers from here:

http://support.amd.com/en-us/download/desktop/previous/detail?os=Linux%20x86&rev=13.4

I opened the install, selected Generate Distribution Specific Driver Package, select Build package for detected OS: Ubuntu/precise. It runs and then gives and error "Sorry, a problem occurred while installing software. Package: fglrx".

After that failed tried it again but just used the first option which says "Install Driver 13.251 on X.Org 6.9 or later 64-bit. I did that, reboot my computer. After rebooting I had the following message on start up: "The system is running in low-graphics mode". I couldn't get any of the options in the menus to work and I could only use the computer my computer using the terminal. I tried uninstalling the drivers using many guides I found but I could never get it back to the generic drivers. I thought the quickest thing to do would be to format, reinstall and just install the drivers fresh.

After reinstalling the ubuntu, I tried following the following guide:

What is the correct way to install propetary ATI Catalyst Video Drivers (fglrx) directly from AMD?

That didn't work. Got to the "sudo dpkg -i *.deb" command and I get the following error "Error! Bad return status for module build on kernel: 3.11.0-18-generic (x86_64)

Then I removed everything and tried this guide:

http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide#Using_Ubuntu-supplied_fglrx.2FCatalyst

This doesn't work either. I get the same error from the above one.

So I've been trying to install this driver all day and can't figure it out. Any help would be appreciated.

Using:

  • Radeon HD 6850

  • Ubuntu 12.04

share|improve this question
    
Use sudo add-apt-repository ppa:xorg-edgers/ppa, sudo apt-get update, sudo apt-get install fglrx. –  Danatela Mar 28 at 6:41
    
That just gives me the errror: need a repository as argument. –  Cake Mar 28 at 6:49
    
Please post the whole output including how did you type command. –  Danatela Mar 28 at 6:50
    
I formatted and reinstalled the OS again. Than I ran this, rebooted, and now it works. Thank you very much. –  Cake Mar 28 at 7:25

1 Answer 1

up vote 0 down vote accepted

Use

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install fglrx

This will bring you latest ATI drivers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.