Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm facing issues when using by very first time my CD/DVD drive in Linux.

Back when I had Linux, it worked normal, CD/DVD rw, but since I didn't use it much, I just removed it from the laptop (you know, I have a HP Pavilion dv4, those ones you can remove safely the CD/DVD unit from, and place a protector instead, to decrease weight). I just connected it again when I needed to use it, and it was ok.

Couple of months ago I started using Linux, first Ubuntu 12.04, and then I'm in ElementaryOS Luna (Ubuntu based), and no problems at all, except for today, that I needed to use my unit and it didn't work. (Need to say here, I installed both versions, Unity and eOS w/out the unit in place, so I guess that messed up some configuration files from the very start)

I have done some research, and some useful info is here, (note: during all the terminal commands, THERE WAS a CD in the unit)

I guess this one is to look up for drives?

~$ wodim --devices
wodim: Overview of accessible drives (1 found) :
 0  dev='/dev/sg1'  rwrw-- : 'hp' 'BD ROM BC-5501S'
~$ mount '/dev/sg1'
mount: can't find /dev/sg1 in /etc/fstab or /etc/mtab

here the /dev dir cdrom, cdrw, dcd and dvdrw, and some others, are in pink, is that normal?

~$ls /dev
autofs           mcelog              sda2      tty30  tty63      ttyS9
block            mem                 sda5      tty31  tty7       uinput
bsg              net                 sg0       tty32  tty8       urandom
btrfs-control    network_latency     sg1       tty33  tty9       usbmon0
bus              network_throughput  shm       tty34  ttyprintk  usbmon1
cdrom            null                snapshot  tty35  ttyS0      usbmon2
cdrw             nvidia0             snd       tty36  ttyS1      usbmon3
char             nvidiactl           sr0       tty37  ttyS10     usbmon4
console          oldmem              stderr    tty38  ttyS11     usbmon5
core             port                stdin     tty39  ttyS12     usbmon6
cpu              ppp                 stdout    tty4   ttyS13     usbmon7
cpu_dma_latency  psaux               tty       tty40  ttyS14     v4l
disk             ptmx                tty0      tty41  ttyS15     vcs
dvd              pts                 tty1      tty42  ttyS16     vcs1
dvdrw            ram0                tty10     tty43  ttyS17     vcs2
ecryptfs         ram1                tty11     tty44  ttyS18     vcs3
fd               ram10               tty12     tty45  ttyS19     vcs4
freefall         ram11               tty13     tty46  ttyS2      vcs5
full             ram12               tty14     tty47  ttyS20     vcs6
fuse             ram13               tty15     tty48  ttyS21     vcs7
hidraw0          ram14               tty16     tty49  ttyS22     vcsa
hpet             ram15               tty17     tty5   ttyS23     vcsa1
input            ram2                tty18     tty50  ttyS24     vcsa2
kmsg             ram3                tty19     tty51  ttyS25     vcsa3
lirc0            ram4                tty2      tty52  ttyS26     vcsa4
log              ram5                tty20     tty53  ttyS27     vcsa5
loop0            ram6                tty21     tty54  ttyS28     vcsa6
loop1            ram7                tty22     tty55  ttyS29     vcsa7
loop2            ram8                tty23     tty56  ttyS3      vga_arbiter
loop3            ram9                tty24     tty57  ttyS30     video0
loop4            random              tty25     tty58  ttyS31     zero
loop5            rfkill              tty26     tty59  ttyS4
loop6            rtc                 tty27     tty6   ttyS5
loop7            rtc0                tty28     tty60  ttyS6
loop-control     sda                 tty29     tty61  ttyS7
mapper           sda1                tty3      tty62  ttyS8

Trying to mount manually

~$ sudo mkdir /mnt/dvdrw
~$ sudo mount /dev/dvdrw /mnt/dvdrw
mount: /dev/sr0 already mounted or /mnt/dvdrw busy
~$ man mount
~$ sudo mkdir /mnt/dvd
~$ sudo mount /dev/dvd /mnt/dvd
mount: no medium found on /dev/sr0
~$ sudo mkdir /mnt/cdrom
~$ sudo mount /dev/cdrom /mnt/cdrom
mount: no medium found on /dev/sr0
~$ sudo mkdir /mnt/cdrw
~$ sudo mount /dev/cdrw /mnt/cdrw
mount: no medium found on /dev/sr0


~$ sudo blkid
/dev/sda1: UUID="e6ef2898-5744-44bc-a9da-65d32f3bab1d" TYPE="ext4" 
/dev/sda5: UUID="c953e0d7-fe23-4514-a579-de52a0be47a6" TYPE="swap"

... and lshw

~$ sudo lshw
PCI (sysfs)  
                description: DVD-RAM writer
                product: BD ROM BC-5501S
                vendor: hp
                physical id: 1
                bus info: scsi@1:0.0.0
                logical name: /dev/cdrom
                logical name: /dev/cdrw
                logical name: /dev/dvd
                logical name: /dev/dvdrw
                logical name: /dev/sr0
                version: 1.86
                capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
                configuration: ansiversion=5 status=nodisc

Here an important file I didn't know about, fstab

~$ cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=e6ef2898-5744-44bc-a9da-65d32f3bab1d /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=c953e0d7-fe23-4514-a579-de52a0be47a6 none            swap    sw              0       0

and trying again to mount manually...

~$ sudo mount /media/cdrom0/ -o unhide
mount: can't find /media/cdrom0/ in /etc/fstab or /etc/mtab
~$ sudo mount /dev/cdrom /media/cdrom
mount: mount point /media/cdrom does not exist
~$ sudo mount /dev/cd /media/cdrom
mount: mount point /media/cdrom does not exist
~$ sudo mount /dev/cdrw /media/cdrom
mount: mount point /media/cdrom does not exist
~$ sudo mount /dev/dvd /media/cdrom
mount: mount point /media/cdrom does not exist
~$ sudo mount /dev/dvdrw /media/cdrom
mount: mount point /media/cdrom does not exist
~$ sudo mount /dev/sr0 /media/cdrom
mount: mount point /media/cdrom does not exist

Any help to get my unit mount correctly CD/DVD? Thanks in advance.

share|improve this question
post the output of lsblk command. – Avinash Raj Mar 28 '14 at 4:32

The question is a bit old by now, but still doesn't have an answer. So:

  • It appears the folder /media/cdrom doesn't exists, that's why you get "mount point ... does not exist".

  • Second, as /dev/cdrom is not included on fstab, if you want to mount it manually you must specify the type of filesystem with the -t parameter. Fortunately, there's an auto option.

So you'll need:

mkdir /media/cdrom
sudo mount -t auto /dev/cdrom /media/cdrom

Hope that helps!

share|improve this answer
Thanks a lot but unfortunately I have no way to test it, since I changed machine and os :( not because of this haha – unmultimedio Feb 19 '15 at 3:12
Well, I guessed after a year this would't need an answer anymore, but hey, who knows :D – curropar Mar 4 '15 at 12:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.