Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

long time lurker/first time poster. I am very new to Linux but seem to have picked some stuff up quick.

Will try to provide as much relevant information as humanly possible:

After installing Ubuntu 12.04 LTS (from a USB stick), I try to update the driver on my graphics cards (MSI Gaming 3G, R9 280X). Once the OpSystem is installed, I start my computer up, bang shift until I get grub, and put nomodeset in so I can get into Ubuntu and download the GPU drivers.

I have tried two methodologies and arrived at the 2 distinct problems:

  1. I have manually downloaded the AMD Catalyst 13.2 (most recent, non-beta) driver, and installed it by unzipping the file, sudo sh *.run --buildpkg Ubuntu/raring, then sudo dpkg -i fglrx*.deb (fyi, most of this information I followed online through a guide). The result is that an Ubuntu gives me a popup that says the fglrx package crashed, and asks me if I want to send a report or something. I say no. Now when I run aticonfig --lsa, all my graphics cards show up. I then run aticonfig --adapter=all --initial which seems to complete a process in a .xorg file or whatever. HOWEVER, when I want to see if my GPU sensors are enabled by running aticonfig --adapter=all --odgt (mostly to do some crytocurrency mining), I receive:

Error - OD Get version failed.

Not sure why. This Error occurs both before and after a reboot. However, it seems that I can actually get into Ubuntu following a boot - just not have all my cards working.

  1. I install the OpSystem (Ubuntu 12.04 LTS - just in case you forgot). I get into Ubuntu using grub (nomodeset). The first thing I do is open terminal and do sudo apt-get install fglrx-updates fglrx-amdcccle-updates fglrx-updates-dev. The second thing is aticonfig --lsa (all my cards appear). Third thing I do is sudo aticonfig --adapter=all --initial then reboot. After doing this, my bios acknowledges its presence, I get a purple screen, then another purple screen with the Ubuntu logo and loading bars, then it goes completely black; no cursor, no anything, but the screen remains on. When doing a reboot and getting into grub for a nomodeset edit, I still encounter the same problem. The ONLY solution is for me to reinstall the OpSystem from scratch.

-Edit: Alternatively, I complete steps 1, reboot. The result is that it boots up fine. However, once I do step 3 and reboot, the problem occurs.

Here is what I know:

  1. All my hardware is functional. I have swapped out a hard drive, motherboard, and multiple gpus. The CPU and ram functioned previously.

  2. I followed the proper operating system installation procedures.

I sense this is an fglrx problem and/or I'm doing something totally wrong. I am truly hoping one of you can spot the problem. I am truly a linux noob.

share|improve this question
    
how to install ati/radeon help.ubuntu.com/community/BinaryDriverHowto/AMD –  JohnnyEnglish Mar 28 at 0:02
    
    
not a duplicate Johnny D. It's a completely different set of problems. Even with going into grub and editing to nomodeset (post install) does not yield any results... –  SameProblemGuy Mar 28 at 0:10
    
did you read and followed all my posts above? these posts helped basically all users when I recommended these workouts, in a post possible duplicate there is a paragraph in answer that says if you have ati/amd video card you can boot to black screen every single reboot and in workout it's recommended Catalyst 13.4 for Ubuntu 12.04 and later and you said you downloaded 13.2 which appears to be old in this case. If you want to install Catalyst manually you should remove fglrx to avoid conflicts. –  JohnnyEnglish Mar 28 at 8:48
    
and also if you install/update new driver it needs to be reconfigured before reboot otherwise it might lead you to black screen after reboot all these steps provided in posts above. –  JohnnyEnglish Mar 28 at 8:50
show 9 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.