Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 11 Server with LXDE. I found that there was no sound. What do I do?

Following Sound Troubleshooting

jm@jm-laptop:~$ gnome-volume-control
** (gnome-volume-control:8750): WARNING **: Connection failed, reconnecting...

jm@jm-laptop:~$ sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

jm@jm-laptop:~$ find /lib/modules/`uname -r` | grep snd
/lib/modules/2.6.38-8-server/kernel/sound/pcmcia/vx/snd-vxpocket.ko
/lib/modules/2.6.38-8-server/kernel/sound/pcmcia/pdaudiocf/snd-pdaudiocf.ko
/lib/modules/2.6.38-8-server/kernel/sound/i2c/snd-cs8427.ko
/lib/modules/2.6.38-8-server/kernel/sound/i2c/snd-i2c.ko
/lib/modules/2.6.38-8-server/kernel/sound/i2c/other/snd-ak4117.ko
/lib/modules/2.6.38-8-server/kernel/sound/i2c/other/snd-ak4114.ko
/lib/modules/2.6.38-8-server/kernel/sound/i2c/other/snd-pt2258.ko
/lib/modules/2.6.38-8-server/kernel/sound/i2c/other/snd-ak4xxx-adda.ko
...

jm@jm-laptop:~$ lspci -v
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 18)
    Subsystem: Dell Device 0419
    Flags: bus master, fast devsel, latency 0
    Capabilities: <access denied>

00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 18) (prog-if 00 [Normal decode])
    Flags: bus master, fast devsel, latency 0
    Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
    I/O behind bridge: 00002000-00002fff
    Memory behind bridge: cfe00000-cfefffff
    Prefetchable memory behind bridge: 00000000d0000000-00000000dfffffff
    Capabilities: <access denied>
    Kernel driver in use: pcieport
    Kernel modules: shpchp

00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06) (prog-if 20 [EHCI])
    Subsystem: Dell Device 0419
    Flags: bus master, medium devsel, latency 0, IRQ 16
    Memory at f0b05800 (32-bit, non-prefetchable) [size=1K]
    Capabilities: <access denied>
    Kernel driver in use: ehci_hcd
 ...

jm@jm-laptop:~$ wget -O alsa-info.sh http://alsa-project.org/alsa-info.sh && bash ./alsa-info.sh
...
Your ALSA information is located at http://www.alsa-project.org/db/?f=711f054c4abd11e4c5570d5f7c315982f9d147e7

The contents of the URL http://pastie.org/1929819

Now what?

share|improve this question
    
Did you get up to the step in troubleshooting that lists alsamixer? Run that and make sure everything is turned up (use arrow keys, and don't forget to hit tab and check you haven't missed anything!) This has fixed this issue for me on many occasions. –  jozzas May 20 '11 at 4:34
    
Oh, and also make sure nothing is muted in there: M mutes/unmutes. If a channel is unmuted, then there is a green box underneath the volume slider. If the channel is muted, the box is grey. –  jozzas May 20 '11 at 4:54
    
ah now it works, I'm not sure why also? I havent did anything just started alsamixer saw that sound seems ok then tried going YouTube ... i.imgur.com/pJrbZ.png ... does just alsamixer do anything to enable sound? –  JM at Work May 20 '11 at 5:00
add comment

2 Answers

up vote 1 down vote accepted

I found that installing

gnome-media pulseaudio 

seems to fix this

share|improve this answer
add comment

I am using Ubuntu 12.04 64bits and I recently installed Xcfe-4 Desktop. When I first logged in xfce-4 I noticed there was no sound at all (Rythmbox, games, etc). And I found no icon anywhere to adjust the sound.

This is how I did to fix the problem :

1) Go to the applications menu > Sound & Video > Mixer.

2) In the Sound Card option menu, select Playback: Built-in Audio Analog Stereo (PulseAudio Mixer).

3) The playback window may be empty. Click on "Select Controls..." , enable/check Master then close.

4) Unmute the sound icon just under the volume bar.

I guess you need to check whether you are using PulseAudio or Alsa drivers. This should not change the fact you need to uncheck mute icon in your "Playback: Audio stereo" in Mixer.

I hope this can help :-)

PS : I am a newbie in linux stuff, so please correct me if I said something wrong.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.