Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Unless I disable proxy, webpages show up as characters like

|ˆSš˜mð{ýîsqÐ|0MVà|ð|}}}0}@}P}`}p}€}P} }°}À}Ð}à}ð}~~ ~0~@~P~`~p~€~P~ ~°~À~Ð~à~€€ €0€@€P€`€p€€€P€ €°€À€Ð€à€ð€AA A0A@APA`ApA€APA A°AÀAÐAàAðA‚‚

or else as a .bin file available for download. For example https://dpaste.de/epVx is what http://stumblingandmumbling.typepad.com/stumbling_and_mumbling/2014/03/ex-growth.html looks like if I go through the system proxy.


If I use w3m through an ssh connection then webpages display fine. TTYtter works fine. vlc can even play the same youtube video at the same time as firefox can't load the site. I infer from this that those programs must use proxies differently.

Once I change the proxy from "system default" to "none" this problem goes away in Firefox. Aliasing w3m to w3m -no-proxy works for naked w3m but not in wrappers like surfraw. However, curl and by extension R still can't fetch data—and even sudo apt-get install is having problems.

I'm not even sure where the system default proxy settings are coming from. If I try to google about it I end up being directed to squid -- which I'm not sure is what I want.

share|improve this question
1  
Which browsers you use that this happens? Also, don't you have a proxy in your network? How you disable the proxy? –  Braiam Mar 30 at 23:37
    
There is no default web proxy server for Ubuntu, at least not on normal installations. On a network you might be forced to use a proxy, though. Have you checked your Firefox configurations and configs on your other browsers to see whether they're even being assigned a proxy? –  Thomas W. Mar 30 at 23:38
    
@Braiam Firefox and w3m both had the problem. –  isomorphismes Mar 31 at 4:48
add comment

1 Answer 1

up vote 2 down vote accepted

The problem was that I had installed anon-proxy but not configured it. anon-proxy uses 127.0.0.1:4001. So either configure it or kill it.

  • How to configure anon-proxy.
  • To kill it use sudo su; netstat -tlp to find the process number of mix (it's called an anonymous mix for some reason) and then from su issue kill -9 to the process id number.
  • If killing doesn't work, then don't just sudo apt-get remove anon-proxy; also sudo apt-get purge anon-proxy; this will unset shell variables like $HTTP_PROXY and some files in /etc/ or /var/ that it may have changed.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.