Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been trying to get HDMI output to work on my laptop which has Intel HD 4600 and NVidia K2100M for graphics managed by bumblebee.

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK106GLM [Quadro K2100M] (rev ff)

xrandr simply shows the cable as disconnected even when it is plugged in, and the monitor displays "No Signal".

VGA1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)

So I was reading the bumblebee documentation here and came across this paragraph:

Optimus laptops have two video chips: an integrated Intel and a discrete nVidia one. If the port (DisplayPort / HDMI / VGA) is wired to the Intel chip, you do not need to do anything special to get external monitors to work.

I was wondering if this could be the problem with my laptop (Dell Precision M4800), and if there was a simple command that would let me test for this hardware configuration. I did not follow through with the rest of the bumblebee documentation as it seems pretty involved and I didn't want to mess things up as this is my primary workstation.

Also, udevadm monitor does not fire an event when the HDMI cable is plugged in/unplugged, but does fire events for VGA when running over Intel graphics.

share|improve this question
Have you tried to set your graphics settings in BIOS to discrete? – Mr.Lee Mar 27 '14 at 21:24
If I do that the laptop doesn't boot. Looks like the nouveau drivers don't recognize the GPU. However, even if I do get it to work, I am assuming I would lose the power savings offered by Bumblebee, in which case it isn't worth it to me. – jeshurun Mar 27 '14 at 21:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.