Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Well everyone, after a long and through investigation into this it looks like I'm going to have to call it quits on this one. I've done just about everything suggested both from this site, and Google, but I seem to have no luck on this issue. I think Ubuntu just does not like the card that I have. Oh well, being a penny pincher has it's downsides. I'm looking into getting a new wireless card soon.

enter image description here

Time elapsed for Ping test to connect = 10s.

Time elapsed for Download test to connect = 6s.

Time elapsed for Upload test to connect = 27s.


Windows XP x86

enter image description here

Time elapsed for Ping test to connect = 3s.

Time elapsed for Download test to connect = 2s.

Time elapsed for Upload test to connect = 6s.

Bus 001 Device 003: ID 148f:9021 Ralink Technology, Corp. RT2501USB Wireless Adapter
Bus 001 Device 002: ID 0bda:0151 Realtek Semiconductor Corp. Mass Storage Device (Multicard Reader)
share|improve this question
    
I would suggest taking 3 test on each OS, and taking an average, you will get a much accurate picture of your speeds, and I bet they will be closer to each other (just a guess) I could be way wrong. –  TheX May 20 '11 at 0:58
    
Hi TheX. I ran about two per OS just to be safe, but then again the internet around here is rather sporadic. What gets me, isn't the difference in download/upload speed, but the time it takes for each test to connect. –  Alan May 20 '11 at 1:04
    
Given the variation between the times of your connection, the use of flash and your relatively poor connection anway these two tests look so similar as to be no indication of one OS working differently than the other. Whatever you do (as suggested in the wise responses below) just don't get your hopes up for any miraculous fix. –  Charles Kane Jun 1 '11 at 14:05
add comment

6 Answers

I've been having this strange problem a while ago on 10.10 as well: downloading files went as fast as on Windows, but browsing web pages went slower than on Windows. After a while, I found the solution myself: I had to turn off the 'share internet connection' option. I hope doing this will resolve your problem as well.

Please notice that the actual button names may differ, for I am using a Dutch version of Ubuntu. I'm not sure about the buttons' names in English.

  1. Click the network icon on the upper bar of the screen
  2. Click 'Edit Connections'
  3. Select the internet connection that you're using, then click 'Edit...'
  4. Untick the box 'Available for all users'
  5. Click 'Save'

Your browsing speed should now be as fast as in Windows XP.

Good luck.

share|improve this answer
    
Hi! Thank you for that tip, I enabled it, and will get back to you if I notice a difference! –  Alan May 27 '11 at 19:06
    
No difference :( –  Alan Jun 11 '11 at 4:45
    
That is too bad. I hope that someone else here will resolve your problem. –  Exeleration-G Jun 11 '11 at 8:16
    
Thanks for your help though mate! –  Alan Jun 15 '11 at 20:27
add comment

The SpeedTest.net results seem equally terrible, so I suspect it might not be actually Internet connection speed issue.

SpeedTest app is Flash. Linux version of Flash is much slower than Windows version. It's also very probable that the Flash version you have on Ubuntu is not the latest, which would make it even slower. That might be one of possible explications why the test take so long to start up, yet produce similar results.

share|improve this answer
    
Hi Vartec. To be sure, I also tried using the SpeakEasy speed test, would that have made any difference? –  Alan May 27 '11 at 19:05
    
SpeakEasy speed test is also Flash. –  vartec May 28 '11 at 17:38
    
Hmm. Well that would explain the time it takes for a test to initiate. But not the slowness in general. One down, one to go. Thanks! –  Alan May 28 '11 at 18:27
1  
other possibility is something with WiFi power saving settings (i.e. in Ubuntu your WiFi card goes into some sleep mode). But I'm not an expert on that. –  vartec May 28 '11 at 18:30
    
Hmm. I'll look into that, good idea. thanks! –  Alan May 28 '11 at 18:33
add comment

You could ping a common site like google.com to get an IP address. Then ping that ip without any name resolution at all. Look at the round trip time for equally sized packets in both windows and ubuntu. If there is a significant difference then I would run traceroute(linux) and tracert(windows) and inspect the roundtrip times for each network hop. This will at least allow you to rule out anything your ISP is doing. If the bulk of the time is spent local to your network you at least have a next step.

share|improve this answer
    
I'll look into that, thanks! –  Alan Jun 11 '11 at 4:44
add comment

I solved a similar issue by signing up for a free OpenDNS account and then using their DNS nameservers (208.67.222.222 and 208.67.220.220). You can specify DNS servers when you edit your connection under network manager. It significantly decreased the time it took to load webpages.

share|improve this answer
    
I currently use OpenDNS, I haven't seen a difference :( –  Alan Jun 11 '11 at 4:45
add comment

I had almost similar experience. I noticed that whenever I am downloading something with Ubuntu, the browser crawls like snails just to open a page. Same thing occurs when I am updating thru the update manager. However when both of the tasks done, the browsing speed goes back to normal. I suspect that the Ubuntu is not 'dividing' the bandwidth equally (not sure what is the better terms for this lol).

Just dont browse while you are downloading. That is what I did.

share|improve this answer
    
of course that happens, when you are downloading you're using your connection, when you're browsing you're using your connection, when you're doing both, the connection speed has to be shared between applications, so obviously it's slow. –  Uri Herrera Jun 4 '11 at 7:28
    
Yup but in ubuntu it definitely slows down browsing speed to crawling. Maybe because of I am using mobile 3g connection instead of fixed one. –  Haikal Nashuha Jun 5 '11 at 3:14
    
yes it gives priority to the download stuff, doesn't matter if it's mobile or wired. –  Uri Herrera Jun 5 '11 at 3:26
    
The slow connection happens whether I'm downloading or not. –  Alan Jun 11 '11 at 4:44
add comment

Bufferbloat could be to blame here. Run this command in a terminal, then try the speed test again.

sudo ifconfig eth0 txqueuelen 0

(Change to wlan0 txqueuelen 50 if you have wireless.)

This causes the Linux's transmit buffer for this interface to be really small. This seems counter-intuitive, but TCP/IP has built-in load adjustment and the network card has its own buffer. Some (bad) wireless cards...do not like having a buffer of 0. This causes your internet to more quickly handle latency and load changes, because it doesn't wait for the buffer to fill up before slowing itself down.

This most greatly affects latency under load which you will have while gaming.

This will NOT persist past a reboot - you can just set the queue length back to 1000 if you want the old behavior.

share|improve this answer
    
Hey Broam. I'll look into this, thanks! Back in my days of Linux Mint I had someone tell me that this is because Linux assigns the 8169 driver to my chipset, rather than the 8168 driver. Although the solution was to download and build a new driver for my ethernet, it seemed to dramatically boost my speed on the wireless. After a few weeks I would notice that the speed would drop again though. What's your opinion on that? –  Alan Jun 15 '11 at 20:30
    
Try blacklisting the 8169 driver. Worst that can happen is the 8168 driver doesn't load and you have to recompile it with the PCI ID for your card. My guess is that a kernel update knocked your driver config out of the way. –  Broam Jun 22 '11 at 16:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.