Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the same issue listed in this question: USB drive install of Ubuntu 12.04 Server fails - can't find components from CD-ROM

My issue differs because I have attempted all of the suggestions in that thread. I have checked the MD5 sum of my downloaded .iso, I used Universal-USB-Installer-1.9.4.3 to create my bootable USB. I get to the same point mentioned in the other question:

[!!] Load installer components from CD

There was a problem reading data from the CD-ROM. Please make sure it is in the drive.
If retrying does not work., you should check the integrity of your CD-ROM.

Failed to copy file from CD-ROM. Retry?

I have run the perl script here: http://cirrus.ucsd.edu/~pierce/fix_ubuntu_usb/ to fix the truncated file names. It found problems with 4 files that it could not fix:

./pool/main/m/maas/python-maas-provisioningserver_1.2+bzr1373+dfsq-0ubuntu1~12.04.4_all.deb
./install/netboot/ubuntu-installer/i386/pxelinux.cfg/default
./install/netboot/pxelinux.0
./install/netboot/pxelinux.cfg/default

There is a file called python...0ubuntu1~12.04.1_all.deb and looking around online there appears to be one available called python...0ubuntu1~12.04.5_all.deb but I cannot find anything about a python...0ubuntu1~12.04.4_all.deb

When I run the Check CD-ROM integrity option, it comes back and says that same file is missing.

When I add the .iso file to the root of the bootable USB and try to mount it by using Alt + F2:

mkdir /cdrom
mount -t vfat /dev/sdb1 /cdrom 

I get an error back saying:

mounting /dev/sdb1 /cdrom failed: Device or resource busy

This computer does not have a CD drive so I am stuck with using a USB install. I do not have a Linux computer available to create the image with. How can I install Ubuntu Server??

Thanks for reading.

Edit

I took a CD drive from another computer and jury-rigged it to this one for the install. Works fine from a CD.

share|improve this question
    
Had similar problems when trying to create live-usb from xp systems. I finally gave up on universal-usb-installer and tried with unetbootin which worked like a charm. It also has a linux version and I think it's included in Ubuntu repositories. –  hmayag Mar 26 at 21:47
    
Though unetbootin was mentioned in the post I referenced as not working, I did try it per your suggestion. It did not help the issue... –  Sarah Kemp Mar 27 at 16:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.