Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 and MSI MS-16GC with Realtek 8723ae and here is my problem. It works with some networks every time (eg. my home network) but it worked with eq. network form my phone (HotSpot) and network on my university but now doesn't. I've tried to do the thing from here but I have this

make -C /lib/modules/3.8.0-35-generic/build M=/home/korek 
/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012 modules
make[1]: Entering directory `/usr/src/linux-headers-3.8.0-35-generic'
CC [M]  /home/korek/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.o
In file included from /home/korek
/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:39:0:
/home/korek/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/pci.h:245:15:   
error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rtl_pci_probe’
/home/korek/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c: In   
function ‘_rtl_init_mac80211’:
/home/korek/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:320:6:   
error: ‘IEEE80211_HW_BEACON_FILTER’ undeclared (first use in this function)
/home/korek/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:320:6:  
note: each undeclared identifier is reported only once for each function it appears   in
/home/korek/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c: In   
function ‘rtl_action_proc’:
/home/korek/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:870:25:   
error: ‘RX_FLAG_MACTIME_MPDU’ undeclared (first use in this function)
/home/korek/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c: In  
function ‘rtl_send_smps_action’:
/home/korek/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:1432:16:  
error: ‘struct <anonymous>’ has no member named ‘sta’
make[2]: *** [/home/korek/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012 
/base.o] Error 1
make[1]: *** [_module_/home/korek 
/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.8.0-35-generic'
make: *** [all] Error 2

What I have to do to get it working every time?

share|improve this question
add comment

1 Answer 1

Update your version of the software. Try version rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012 (Note the last part is the date, which is later than yours). Even later versions may exist, but the above should work.


Here's a similar problem with suggested solution: Wireless card Realtek RTL8723AE-BT driver not compiling on Quetzal

share|improve this answer
    
It still the same. Even Errors are the same –  user2255510 Mar 26 at 18:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.