Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just bought a new notebook, HP 250 G2, with no operating system (only FreeDOS) so I thought I could just install Ubuntu without any of the problems I had previously experienced on other machines with Windows 8 pre-installed... I'll start by saying that I don't know anything about UEFI, EFI, Legacy and stuff like that, so be patient with me. Anyway, Ubuntu wasn't loading from the live usb so I did the nomodeset thing (found on this forum), and finally managed to install it. After installation, I see the grub menu, but when I try and load it, it just shows the purple screen and doesn't go forward. I tried with both normal and recovery mode, and also tried with the nomodeset again but no luck so far. Ubuntu just doesn't load... Is there anything that I can do to solve it? I tried disabling the UEFI mode but my BIOS setup doesn't have the option to disable it (and same thing for the secure boot). The only thing I can disable is the Legacy mode...

As I need an operating system asap in order to be able to work from home tonight, I now tried to install Windows 8 from the installation cd, but now it doesn't load either! Everywhere I go, I keep seeing the grub menu with the options of the installed Ubuntu (of course the ubuntu live usb is no longer inserted).

Please help somehow, thanks!

UPDATE: now when I want to load Ubuntu from the live usb, it goes to a propt page with "ubuntu@ubuntu:^$", waiting for a command...

share|improve this question
    
Wait, how did Windows 8 load before? – Elliott Frisch Mar 26 '14 at 17:02
    
Windows 8 was never installed on this machine before Ubuntu. I only thought of installing it after the Ubuntu installation had failed... – user262297 Mar 27 '14 at 14:49

HP 250 G2 has a stupid UEFI that that can not be disabled. There is an "os boot manager" preceding any other boot manager from hard disk.

Press F9 during start up to access BIOS boot menu order and select ubuntu (if ubuntu was correctly installed)

share|improve this answer
    
hm .. how would you make this default? – user568021 Jan 25 at 20:44
    
I don't know if my problem was the same, but I removed all non-ubuntu partitions and it boots ok now.. needed a day to figure that out. I posted a little rant on hp forums: h30434.www3.hp.com/t5/Notebook-Operating-System-and-Recovery/… – user568021 Jan 26 at 13:15

in the 2nd time:

  1. Type:

    sudo apt-get install efibootmgr
    

    into the terminal window.

    When asked whether you want to continue press "y".

  2. After the installation has completed type

    efibootmgr
    

    into the terminal window.

    boot devices will appear.

    As you can see in my list there are the following boot options:

    boot0000 for Ubuntu (this is an old version and can be ignored)
    boot0001 which is Windows
    boot0002 and boot0003 are two LAN devices
    boot0004 which is the new version of Ubuntu that I just installed
    boot0005 is my USB device
    boot0006 and boot0007 are two other LAN devices
    boot0008 is another USB device
    
  3. Command:

    sudo efibootmgr –o 4,1
    

    –o says that I want to change the order. Then all I have to do is list the order I want things to boot.

    So in the command above I have stated I want Ubuntu to boot first and then Windows.

  4. Choose to shutdown and reboot your computer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.