Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just bought a new notebook, HP 250 G2, with no operating system (only FreeDOS) so I thought I could just install Ubuntu without any of the problems I had previously experienced on other machines with Windows 8 pre-installed... I'll start by saying that I don't know anything about UEFI, EFI, Legacy and stuff like that, so be patient with me. Anyway, Ubuntu wasn't loading from the live usb so I did the nomodeset thing (found on this forum), and finally managed to install it. After installation, I see the grub menu, but when I try and load it, it just shows the purple screen and doesn't go forward. I tried with both normal and recovery mode, and also tried with the nomodeset again but no luck so far. Ubuntu just doesn't load... Is there anything that I can do to solve it? I tried disabling the UEFI mode but my BIOS setup doesn't have the option to disable it (and same thing for the secure boot). The only thing I can disable is the Legacy mode...

As I need an operating system asap in order to be able to work from home tonight, I now tried to install Windows 8 from the installation cd, but now it doesn't load either! Everywhere I go, I keep seeing the grub menu with the options of the installed Ubuntu (of course the ubuntu live usb is no longer inserted).

Please help somehow, thanks!

UPDATE: now when I want to load Ubuntu from the live usb, it goes to a propt page with "ubuntu@ubuntu:^$", waiting for a command...

share|improve this question
    
Wait, how did Windows 8 load before? –  Elliott Frisch Mar 26 at 17:02
    
Windows 8 was never installed on this machine before Ubuntu. I only thought of installing it after the Ubuntu installation had failed... –  user262297 Mar 27 at 14:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.