Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have posted seen this on the Ubuntu forums (http://ubuntuforums.org/showthread.php?t=2175057), but its not drawing a solution there so I am posting here.

Problem is when I shutdown my computer it restarts.

This ONLY happens if I have put the computer into suspend at some point since the last boot. This means that once the computer reboots once, I can shut it down fine, as long as I don't put it into suspend again.

Shutting down from the command line, or GUI makes no difference.

Whether I activate suspend via lid close or from the GUI makes no difference.

Problem is on a Thinkpadx31e (Intel) and has persisted across 12.04, 12.10, 13.04, 13.10.

Any ideas on what I do to fix this annoying bug?

@terdon: Some people have mentioned problems with networking/wifi cards. On this point, perhaps it is useful to also point out that I was having problems with my Broadcom BCM43228 chip, as the proprietary driver was causing the system to freeze when on battery power. I changed to an intel Centrino wireless chip and that solved the problem of freezing. The reboot problem on shutdown, after suspend, persisted across the different chips.

@terdon: I see two potential problems in var/log/pm-suspend.log. One pertains to failed connections and gives the following:

Running hook /usr/lib/pm-utils/sleep.d/60_wpa_supplicant suspend suspend:
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
/usr/lib/pm-utils/sleep.d/60_wpa_supplicant suspend suspend: success.

The other pertains to a suspend not being applicable:

Running hook /usr/lib/pm-utils/sleep.d/95hdparm-apm suspend suspend:
/usr/lib/pm-utils/sleep.d/95hdparm-apm suspend suspend: not applicable.

This second error has a different file causing the problem in different instances: eg.

/usr/.../sleep.d/75modules
/usr/.../sleep.d/90clock
/usr/.../sleep.d/95anacron
/usr/.../sleep.d/95hdparm-apm

Do you need to know all of the different ones?

share|improve this question
    
Wild stab in the dark: does this also happen if you are not connected to a network? –  terdon Mar 26 at 15:33
    
No, it makes no difference. If i disable networking, reboot, engage suspend and try and shut-down (all without re-enabling networking), the machine still reboots. –  MorrisseyJ Mar 27 at 8:46
    
Is there anything interesting in /var/log/pm-suspend.log? Have you perhaps made any changes to the files in /etc/pm/sleep.d/ or /etc/pm/power.d/? Also check those in /etc/acpi/. The thing is that this is incredibly hard to debug from a distance. I'm just throwing files at you hoping one of them might stick. –  terdon Mar 27 at 13:53
    
Thanks again for following this up. What sort of thing should I be looking for in /var/log/pm-suspend.log? (i don't really know how to interpret this, i could run a cycle and post the log if that would be useful). I haven't fiddled with any of those other files that you mention, other than to install TLP. –  MorrisseyJ Mar 27 at 14:25
    
I don't really know. I might if I see it but then again I might not. These are just files that might be involved in this and if you've done anything to them you might remember. The ones in /var/log are logs so any errors might be logged there. Those will be the easiest to sift through. –  terdon Mar 27 at 14:47

1 Answer 1

up vote 0 down vote accepted

Problem was fixed with an update to 14.04.

Not sure what did it, perhaps it was the switch to lightdm to manage the lock screen.

share|improve this answer
    
A recent up date (last week) appears to have broken this again and I am back to the old reboot behaviour. Could anyone help me diagnose? –  MorrisseyJ May 30 at 14:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.