Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I went to lunch for some time and forgot to plug in charger to laptop. After coming back plugged in the charger and started my machine. my internet was not working. So, I checked following things

 * Restarted my Laptop.
 * Removed Ethernet cable and connected again.
 * checked ethernet cable with other laptop.
 * Checked by connecting my laptop to other port.
 * checked by connecting other laptop my port.
 * Network Connections and edited the ethernet connection. Tried deleting and recreating them.

Still my internet was not working: On firing following command I got some error,

$ sudo /etc/init.d/networking status
[sudo] password for user: 
ERROR: Calling a sysvinit script on a system using upstart isn't supported. Please use the 'service' command instead.

Since then I run other comand

sudo service networking restart

Every application running has got terminated and my machine just hanged. I could not do anything at all. Since then turned off manually and started. Still internet was not working. This has happened lots of times earlier. Automatically it starts another day.

Here is my ifconfig :

$ ifconfig
eth0      Link encap:Ethernet  HWaddr 14:fe:b5:bd:1d:7a  
          inet6 addr: fe80::16fe:b5ff:febd:1d7a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4480 errors:0 dropped:0 overruns:0 frame:0
          TX packets:189 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:395705 (395.7 KB)  TX bytes:42279 (42.2 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1438 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1438 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:130259 (130.2 KB)  TX bytes:130259 (130.2 KB)

wlan0     Link encap:Ethernet  HWaddr 38:59:f9:24:01:3f  
          inet6 addr: fe80::3a59:f9ff:fe24:13f/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
share|improve this question
1  
can you go to Network icon and edit the connections. Try deleting and recreating them. –  cytasos Mar 26 at 11:52
    
Even I tried that. Thanks I'll update the question, Had forgot it. –  Laxmikant Gurnalkar Mar 26 at 11:56
    
maybe the Net card has died or are turned off---- can you do --- ifconfig --- in a terminal and post the results --- if you see eth0 or wlan0 you can do --- sudo ifconfig eth0 up -- to start them up –  cytasos Mar 26 at 12:03
    
@Tasos : Have added ifconfig. Can you please help me now? –  Laxmikant Gurnalkar Mar 26 at 12:35
    
in a terminal can you do ---- ping 192.168.0.1 --- do you get a reply. also do --- ping google.com –  cytasos Mar 26 at 12:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.