Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm attempting some streaming with FFMpeg, and I think I have finally found the solution I need to screen blanking. This requires writing PNG's to a named pipe and then having FFMpeg read them as an overlay. However, I seem to be having a weird issue.

#!/bin/bash

mkfifo /tmp/stream_pipe
cat /path/to/transparent/or/splash/screen.png > stream_pipe
echo "done!"

In this example, echo "done!" never actually runs.

So, I moved to the terminal and tried the same thing, and sure enough the cat command hangs indefinitely.

I don't recall ever having issues with catting to named pipes and, indeed, I saw a lot of named pipe references that use just this. What could possibly be going wrong here? Shouldn't cat exit once it has finished writing the file to the pipe? The file being written is just a normal PNG file, so this has really got my puzzled.

Or is it that cat attempts to close the pipe upon writing perhaps? This would make sense why it would hang since it's not a legitimate file, but I would imagine that cat would know the difference or wouldn't care.

EDIT: cat $file | echo -n > /tmp/stream_pipe exhibits the same behavior

share|improve this question
    
Can't check now, but you probably need to read the other side of the pipe... Try to do a cat /tmp/stream_pipe > /dev/null in another terminal. I seems to remember that the pipe will cache around 4k of data and then block, waiting to be emptied. –  Rmano Mar 26 at 4:53
    
Is there any way to increase that limit, seems to the be problem I'm running into now that I got it to work. –  Githlar Mar 26 at 5:57
    
I don't think, but shouldn't be a problem. Put your cat >pipe in background and let the multitasking do the magic... –  Rmano Mar 26 at 14:01
    
That's the thing, this file wasn't enough to clog or saturate the pipe. So, it should have executed without issue. The file was only 300k or something, but the pipe buffer is 1M. –  Githlar Mar 26 at 16:35

2 Answers 2

You need to have something reading from the FIFO.

Try this:

#!/bin/bash 

mkfifo /tmp/stream_pipe
cat /path/to/transparent/or/splash/screen.png > stream_pipe &
cat stream_pipe
echo "done!"

You should get the contents of the file printed to the screen (same as if you do cat /path/to/transparent/or/splash/screen.png).

share|improve this answer
    
ffmpeg is reading from the FIFO. –  Githlar Mar 26 at 5:57
up vote 1 down vote accepted

cat $file >/tmp/stream_pipe didn't work, but I was able to make it work (to some degree) by assigning the pipe to a file descriptor like so:

#!/bin/bash

exec 3<>/tmp/stream_pipe
cat /path/to/file.png >&3

I said it works to some degree, because running it stand-alone clogs the pipe and the script appears to hang. This is due to the fact that pipes in Ubuntu have a 1M buffer limit as seen via the command systcl fs.pipe-max-size. Unfortunately, settings this value via sysctl doesn't seem to change it. However, so long as the pipe data is being consumed by another process, there shouldn't be an issue. Any writes to a full pipe will block (it looks like a hang, but it's not) until data is consumed at which point the write will continue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.