Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello I'm having a problem with updating my system. I'm running precise 12.04

When I run apt-get update, I get the following error at the end of the apt-get update.

Failed to fetch http://archive.canonical.com/dists/precise/partner/binary-i386/Packages  404  Not Found [IP: 91.189.92.150 80]

I've tried changing servers and this doesn't work either. It gives me a message to check my internet connection which is solid. So now when I open update manager it says the last time the package information was updated was 7 days ago. So it seems I can't update my system anymore.

I was going to copy below the read out from the terminal when I run sudo apt-get update but it won't let me post a question with more than 2 links in it because my reputation isn't high enough and the apt-get update read out is full of links...

I'm very new to linux and xubuntu, can someone please help me.


UPDATE - SOLVED

I found a solution to my problem here.
http://ubuntuforums.org/showthread.php?t=2046145

At some point I must have screwed with my sources list. I followed the instructions provided and basically copy/pasted the sources list provided in the answer by Lisiano located at the above link and ran apt-get update and it worked. Sweet as cheese.

Thanks to Lisiano for the step by step solution.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.