Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm sharing my PC with my wife and my sister on regular basis. There are several issues when we switch from one user to another, such as the NetworkManager icon being present only on the first account (which is ridiculous).

A similar problem occurs when there is a DVD in the drive. When a second user logs in, the DVD cannot be seen (unmounted, ejected) until you physically eject the disk (i.e. press the button on the drive itself) and reinsert it.

My amateurish guess tells me that automount mounts the disk with the current user's permissions[citation needed] so the other can't unmount it. This is a bit absurd since every user has the "Mount user-space filesystems (FUSE)" and "Use CD-ROM drives" permissions (I am the only sudoer, though).

Is there any way this could be "fixed"? It's only a nuisance, but I can already see my co-users asking questions and being annoyed.. :)

share|improve this question
    
The network manager thing is a reported bug on launchpad. But apparently, it was working once, and then a change was made to make it so only one instance runs on a user. Problem is that that change made it so only one instance would run computer wide! IIRC, there's a major new version (still in testing phases) that fixes this. And yes, it is annoying. –  Azendale Mar 11 '12 at 18:08
1  
    
Thanks @Azendale, I've run into some of these links myself. My workaround for a while is a small script which kills NM and then starts it again. If any of my users has trouble with the WiFi, they simply use the script and "claim" the NM for themselves. –  dr Hannibal Lecter Mar 12 '12 at 10:31

1 Answer 1

First I have no solution only a workaround guess...

If you often use the same DVD try to copy these files in local folders or create an ISO-file and set up the right group permissions...

Additionally you can deactivate automount (option no-auto in /etc/fstab) and mount the dvd by yourself via command line. In this case you can mount to an local folder with useful group permissions for your accounts

I hope this would be helpful

share|improve this answer
    
I see your point, but I think my wife and my sister would have something to say if I deactivate automount... :-) If it were only a single DVD, I wouldn't be asking this question ;) –  dr Hannibal Lecter Sep 23 '10 at 19:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.