Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since a week I am a ubuntu user. Switched from windows since my paid xp license is not supported anymore. Iḿ really satisfied about ubuntu, works perfectly!

Just one small problem, that's my screen resolution. I'm using a Iiyama ProLite E1902WSV monitor on ubuntu 12.04 LTS

When I put the code xrandr in the terminal, I get the following:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
VGA-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
DVI-D-1 disconnected (normal left inverted right x axis y axis)
TV-1 disconnected (normal left inverted right x axis y axis)

And now the problem starts, becouse the optimal screen resolution for my Iiyama isn't in this list. I've looked around on the internet and the best resolution should be 1440x900 (source)

Does anybody know how to fix this? Thanks in advance!

:::EDIT:::

After the solution from Sylvain Pineau I started my computer this morning and got the following message.

none of the selected modes were compatible with the possible modes:
Trying modes for CRTC 143
CRTC 143: trying mode 1024x768@60Hz with output at 1440x900@60Hz (pass 0)
CRTC 143: trying mode 800x600@60Hz with output at 1440x900@60Hz (pass 0)
CRTC 143: trying mode 800x600@56Hz with output at 1440x900@60Hz (pass 0)
CRTC 143: trying mode 848x480@60Hz with output at 1440x900@60Hz (pass 0)
CRTC 143: trying mode 640x480@60Hz with output at 1440x900@60Hz (pass 0)
CRTC 143: trying mode 1024x768@60Hz with output at 1440x900@60Hz (pass 1)
CRTC 143: trying mode 800x600@60Hz with output at 1440x900@60Hz (pass 1)
CRTC 143: trying mode 800x600@56Hz with output at 1440x900@60Hz (pass 1)
CRTC 143: trying mode 848x480@60Hz with output at 1440x900@60Hz (pass 1)
CRTC 143: trying mode 640x480@60Hz with output at 1440x900@60Hz (pass 1)
Trying modes for CRTC 144
CRTC 144: trying mode 1024x768@60Hz with output at 1440x900@60Hz (pass 0)
CRTC 144: trying mode 800x600@60Hz with output at 1440x900@60Hz (pass 0)
CRTC 144: trying mode 800x600@56Hz with output at 1440x900@60Hz (pass 0)
CRTC 144: trying mode 848x480@60Hz with output at 1440x900@60Hz (pass 0)
CRTC 144: trying mode 640x480@60Hz with output at 1440x900@60Hz (pass 0)
CRTC 144: trying mode 1024x768@60Hz with output at 1440x900@60Hz (pass 1)
CRTC 144: trying mode 800x600@60Hz with output at 1440x900@60Hz (pass 1)
CRTC 144: trying mode 800x600@56Hz with output at 1440x900@60Hz (pass 1)
CRTC 144: trying mode 848x480@60Hz with output at 1440x900@60Hz (pass 1)
CRTC 144: trying mode 640x480@60Hz with output at 1440x900@60Hz (pass 1)

Is there a solution to this aswell? I have the same screen resolution as in the beginning 1024x768 (4:3) again...

share|improve this question
    
possible duplicate of Screen resolution stuck at 1024x768 –  Sylvain Pineau Mar 25 at 14:00
    
In the case you redirecting to is the resolution he needs at least in the xrandr result. In my case I can't find the resolution of my monitor at all in that result. I need the 1440x900 and the biggest available in the xrandr is 1024x768 (not even widescreen) –  Thijs Mar 25 at 19:58
    
Did you try xrandr --newmode "1440x900_60.00" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync and xrandr --addmode VGA-1 1440x900_60.00 –  Sylvain Pineau Mar 25 at 20:04
    
Welcome to Ask Ubuntu. Please, could you put some of your time to read askubuntu.com/help/someone-answers –  Sylvain Pineau Mar 25 at 22:08

1 Answer 1

up vote 3 down vote accepted

Try first to define a VIRTUAL1 display:

xrandr --newmode "1440x900_60.00" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync

And use it to set the profile of VGA-1:

xrandr --addmode VGA-1 1440x900_60.00
share|improve this answer
    
Wonderfull!! This worked perfectly! Thank you very much!! –  Thijs Mar 25 at 21:44
    
Please up vote my answer and mark it as accepted. –  Sylvain Pineau Mar 25 at 22:09
    
I wass to early to be happy... See my edit in the first post (is to long for comment) –  Thijs Mar 26 at 12:58
    
Please check this question to store your new settings permanently. –  Sylvain Pineau Mar 26 at 13:08
    
I may be to stupid to imagine, but I still can't fix it. When I change the lightdm.conf file it says that I can not save it becouse it's a read-only file. –  Thijs Mar 26 at 18:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.