Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday i've installed ubuntu 11.04 (instead of 10.10). And i need to install nvidia driver which supports opengl 3.3 In 10.10 i did it in a such way:

Ctrl+alt+f1 login

sudo /etc/init.d/gdm stop
sudo sh driver.run 
startx

Not it doesn't work. Because ctrl+alt+f1 doesn't show login screen. Just only black screen. I've googled this problem. Some people have it but no one knows how to solve. Sometimes people say that it is connected with video card or driver. But i have GeForce 9300M G, and i've activated a standard driver. Anyway, it worked in 10.10, but doesn't work now.

The main problem is that i need to kill xserver to install this driver. killing the process just only restarts xserver.

Also, I've tried to /etc/init.d/gdm stop in GUI-console. It says that "Fake initctl,doing nothing". Google didn't helped in this case too.

Any ideas to install that driver?

share|improve this question

migrated from stackoverflow.com May 19 '11 at 16:33

This question came from our site for professional and enthusiast programmers.

add comment

3 Answers 3

Installing drivers the official way

The supported way to install hardware drivers is by running System->Administration->Additional Drivers from the classic session.

When you install drivers from Additional Drivers, choose the recommended driver and enable it. Once you have done this, the window should look something like this:

alt text

I have a similar card (GeForce 9300M GS) and this driver works well.

You should only install drivers from .run files if:

  1. You don't have an internet connection on your Ubuntu computer.
  2. There is no other way to install the drivers.

Installing graphics drivers from .run files

I have, in the past, been without an internet connection due to a Windows XP only modem. These are the steps I took to install my (NVidia) graphics drivers (original forum post):

  1. Save the .run file in your home folder. This should have the path /home/YOURUSERNAME. You can get to this from Places->Home Folder.
  2. Press Ctrl+Alt+F1. This should bring up a text mode command line interface.
  3. Log in by first entering your user name then your password. Note that when you enter your password you will not see the letters of your password appear on the screen while you type. This is normal and is done for security reasons.
  4. Once logged in, enter the following commands by typing them in, then pressing enter:

    cd ~

    sudo /etc/init.d/gdm stop

    sudo chmod +x driver.run

    sudo ./driver.run

  5. Wait for the installer to finish then enter this command: sudo /etc/init.d/gdm start. This should bring back the graphical interface.

  6. I'm not entirely sure if this step is required and, to be honest, I don't know what it does but when I installed the driver I opened a terminal Applications->Accessories->Terminal and entered this command: sudo nvidia-xconfig --add-argb-glx-visuals. This enabled me to enable visual effects.

share|improve this answer
add comment

Boot in recovery mode and choose root (or netroot) - that would not start X, but drop you to root shell on tty1 instead.

share|improve this answer
add comment

You normally want to install the driver from the repos (sudo apt-get install nvidia-current) but I'm not sure if that supports opengl 3.3. This is how you would run the driver:

(save all your data)

sudo telinit S

pick "root prompt"

./driver.sh
sudo reboot
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.