Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I start my local ssh login I have to wait for seconds to write a complete command. Even "ls" is taking so much time.

I am using it wireless with two of my linux laptops and connecting to my college wifi network.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

If

  • you have a very weak wireless signal, or
  • the wireless network is under extreme load (this would happen from lots of data being sent between computers on the wireless LAN, but probably not just from Internet access across a wireless AP/router), or
  • your wireless network is ad-hoc (which gets slow fast once you have more than two computers communicating)

...high latency like this can happen.

Besides that, and perhaps some other conditions I haven't thought of, this isn't normal--not when SSHing from one local machine to another using the server's local name or IP address. (If you're connecting through the router so it's as though you were connecting over the Internet, but bouncing back to the SSH server, that might be a different story. This will happen if port forwarding or NAT-based DMZ is set up to the SSH server and you access it through its WAN--i.e., Internet-facing--hostname or IP.)

So more troubleshooting would be a good idea. You may want to start by expanding your question with details about whether or not anything else is slow over this network.

One thing you can try now to increase performance is to use the Blowfish cipher with SSH. So if you're currently running:

ssh hostname

You'd run this instead:

ssh -c blowfish hostname

Blowfish has a reputation for computational speed, and I've seen speed improvements with it in SSH on some systems... but I don't know if it's actually the fastest (of all sufficiently secure) ciphers supported. Perhaps someone knowledgeable about these matters can post another answer that goes into more detail about cipher choice.

You can enable compression too (with the capital -C flag), but I think it probably won't help much, and may even worsen the problem significantly if either of the machines has an old, slow processor or is under very high load.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.