Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am pretty new to ubuntu and I am experiencing a problem that hopefully someone can help me with. I have a HP N54L server that I have had XBMCbuntu running on for about 12 months now. I have a radeon HD6450 video card in it that I use to connect to my TV. I have caused a problem whilst trying to install Teamviewer which originally made the resolution 640x480. My attempts to "fix" this problem has now caused me to not have any video output at all. Even on initial startup (BIOS) there isn't any output at all. All I get is a blank screen via the on board VGA and No Signal on my TV via the HDMI on the HD6450.

Looking at the system remotely it seems fine. I can still ssh into it. I can still get to my web GUI of all of the services that I am running (sickbeard, couchpotato etc.) and they are all working as they should. Locally however I can't do anything as I have no video whatsoever.

Steps taken to create the fault:

  1. Installed Couchpotato and configured - working perfectly

  2. Installed Teamviewer remotely via ssh

  3. Started the teamviewer daemon remotely via ssh

  4. Couldn't get the status of teamviewer to work and give me the ID so that I could log in and connect to it remotely.

  5. Checked the physical machine and and the resolution was set to 640x480

Attempts to fix

  1. As this is XBMCbuntu it loads by default to XBMC so I went to the settings menu within XBMC to change the resolution back to 1080p but there were no other available resolution options.
  2. Reboot - still the same
  3. Quit XBMC and log on to ubuntu desktop - still 640x480

  4. Tried to install proprietary drivers (although from memory I think that catalyst control centre was available in settings already so it may have already been using that driver)

  5. reboot

  6. No video, not even in on boot

  7. Panic took hold and I tried uninstalling drivers, installing Radeon standard driver etc etc but I just can't get it to work.

  8. Found an older xorg.conf file that I had backed up from a few months ago when I must have edited it for some reason. The driver is set as fglrx so it was already configured with that driver anyway so I probably never had to mess with it

  9. Copied this old xorg.conf onto the system

  10. I can no longer ssh into or ping the machine

  11. Found a forum thread and followed the suggestion I found there. Ran:

    sudo apt-get remove --purge xorg-driver-fglrx fglrx*
    sudo apt-get remove --purge fglrx*
    sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases
    sudo apt-get install --reinstall
    libgl1-mesa-glx libgl1-mesa-dri
    sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
    sudo dpkg-reconfigure xserver-xorg
    
  12. I removed the HD6450 video card out and managed to get it booted with the onboard VGA. It booted up to a menu which I think is grub. I selected ubuntu from the menu and it brought up the XBMC logo but then went to a black screen after this. At this point I could ping again.

  13. I am now using the old xorg.conf file and it gives a pretty good resolution over the on board VGA.

  14. Put the 6450 back in. Still no output on HDMI as expected BUT I hooked up the VGA that comes with the 6450 and it is sending video out on that. It is only 640x480 though.

Current state of affairs

I now have pretty decent resolution on the 6450 via VGA but just not getting anything on the HDMI. When I run xrandr it says DFP1 and DFP2 are disconnected. I am pretty sure that DFP1 is the HDMI. I need that to be 1080P!

How can I get 1080P on this machine over HDMI again? I would prefer not to reinstall but if I do, will I lose data?

share|improve this question
    
Welcome to Ask Ubuntu! It is preferred if you can post separate questions instead of combining your questions into one. That way, it helps the people answering your question and also others hunting for atleast one of your questions. Thanks! –  Danatela Mar 25 at 3:58
2  
We don't need to know what you were thinking or where you were, this is not a novel :). I tried to trim this a little and make it less of a wall of text. I actually did read it but rest assured that most users will just run away in horror. Please go over my changes, and make sure this still describes your situation. –  terdon Mar 25 at 4:05
    
Thanks. That is way better. Apologies but I was typing things out as I went at about 2am when I should have been sleeping.... –  user261782 Mar 25 at 4:32
    
"I would prefer not to reinstall but if I do, will I lose data?" If you do a backup, no. –  Braiam Mar 25 at 4:32
    
BTW, can you tell me exactly what is the problem? And include the output of DISPLAY=0 xrandr. –  Braiam Mar 25 at 4:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.