Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After attempting to use a VPN client (Astrill), I can no longer access the internet through my Ubuntu installation. The VPN was setup as piece of software, not something to be used through Ubuntu settings.

Its not a network issue, as on the same Wifi and wired network both my Windows install and other comps can connect and use the network.

I can, however, connect to sites via a proxy client running through WINE. I've tried changing proxy settings, but to no avail. I'm really at a loss and have no idea what I should do,

Whenever I try to run Firefox, I get almost immediately "Unable to connect" and when I try to update (sudo apt-get update) in the terminal, it immediately comes back with cannot find. There isn't a moments hesitation, just bam! can't do it!

share|improve this question
    
Can you please edit your question to include the output of route? –  ændrük May 19 '11 at 15:02
    
@ændrük edited. As you can imagine, I have no idea what any of it means... –  Knowsnothing May 20 '11 at 3:56
    
what's the output of cat /etc/network/interfaces and cat /etc/resolv.conf Make your interfaces & dns settings are set right. for dns you could just set google ones: 8.8.4.4 , 8.8.8.8 –  Salimane Adjao Moustapha May 20 '11 at 5:37
add comment

2 Answers

up vote 0 down vote accepted

I had the same problem. After some research in my config files I found out that Astrill is changing /etc/resolv.conf and is not reverting it to the original state after switching off.

You can get your normal internet connection by deleting this file and restarting your network (rcnetwork restart under opensuse)

I reported this bug to Astrill and I am hoping they are fixing this soon.

share|improve this answer
    
Thanks! When I talked to them, they said that the client didn't make any changes. Good thing it was only a trial! Needless to say, I decided to go with one of their competitors. –  Knowsnothing Jun 2 '11 at 4:13
    
may I asked which vpn you are using now, my astrill trial will end soon as well ;) –  florian Jun 2 '11 at 8:04
    
Hey, just saw your question! I'm using Witopia. It works pretty well, but they do have restrictions over what you can download (ie copyrighted content) –  Knowsnothing Jun 22 '11 at 2:51
    
@N.N. I'm thinking about going back to Astrill. Did they ever get this worked out? –  Knowsnothing Apr 24 '12 at 4:34
add comment

If you are using the command line for your internet through proxy, adding the proxy to /etc/apt/apt.conf will help.

Also, check if you have added the proxy settings to the network proxy and applied it system-wide.

If things dont work immediately, try restarting the computer and see if it works. Proxy in Ubuntu works weirdly. I have had a hell lot of problems in the past few weeks getting it to work. NOw everything works without a hitch.

One more thing, if by any chance this highlighted feature in the screenshot below of the vpn connection config is enabled, i have seen , you dont get internet. Try unchecking this option.

Connection description for vpn

share|improve this answer
    
@Ubuntuser The problem doesn't seem to be in the proxy settings as I can't make the system use my proxy client (its an exe running through WINE). I can configure programs to use it, but it never seems to work if I make it a system setting. The VPN was a piece of software, not something I configured on Ubuntu itself. –  Knowsnothing May 20 '11 at 7:47
    
@Ubuntuser The thing is, I don't want to use a proxy all the time. Its slow and can't handle much traffic. I want my normal connection back. –  Knowsnothing May 20 '11 at 7:55
    
There are two options here. 1) You are using Astrill VPN Client which is open vpn format. Why dont you use openvpn gnome client instead? 2) Astrill has native linux software you can download from astrill.com/download.php# including a cli installer. Try them. –  Ubuntuser May 20 '11 at 7:58
    
As far as I know, you can use vpn and proxy on a on demand basis. When you want it , just connect the vpn and turn on proxy. When you dont want just turn them off. Thats what I do for my cisco vpn connection. –  Ubuntuser May 20 '11 at 8:00
    
@Ubuntuser Right! But when I don't have the proxy on, I can't access anything, not even the VPN! –  Knowsnothing May 20 '11 at 8:25
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.