Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm struggling with Ubuntu for almost 3 months now. And it never fails to drive me crazy. I'm using Ubuntu for compiling Android kernels for beaglebone black. I installed Ubuntu into a separate physical harddrive. After I finished my work with it, I disconnected that harddrive and didn't use it until today. This morning I reconnect my Ubuntu harddrive and tried to boot Ubuntu. And suprise suprise. It didn't boot up. Since I didn't care the files in harddrive, I formated it and installed a brand new Ubuntu.

Now I am following the exact steps I did before for kernel compiling. I need several packages to install for compiling an Android kernel. One of them is "libglapi-mesa" . I am using following shell command to install it:

apt-get install libglapi-mesa

But it acts differently and doesn't install the package. Here is the response of shell:

Reading package lists... Done

Building dependency tree

Reading state information... Done

Note, selecting 'libglapi-mesa-lts-saucy' instead of 'libglapi-mesa'

libglapi-mesa-lts-saucy is already the newest version.

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded

I've used the same Ubuntu 12.04.4 setup. And in the past it was installing the package I want, now it doesn't install it. It says "selecting 'libglapi-mesa-lts-saucy'" and "libglapi-mesa-lts-saucy is already the newest version." but I don't want these packages because when I try to run

sudo apt-get install git-core gnupg flex bison gperf build-essential \
  zip curl libc6-dev libncurses5-dev:i386 x11proto-core-dev \
  libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-glx:i386 \
  libgl1-mesa-dev g++-multilib mingw32 openjdk-6-jdk tofrodos \
  python-markdown libxml2-utils xsltproc zlib1g-dev:i386 \
  minicom tftpd uboot-mkimage expect libgl1-mesa-dri

It fails, because it needs 'libglapi-mesa' .

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

As you can see from package search the package libglapi-mesa in 12.04 neads one of the variants libglapi-mesa-lts-quantal or libglapi-mesa-lts-raring (or libglapi-mesa-lts-saucy within precise-updates). It seems as if these are backported versions of newer Ubuntu releases. It is the same for libgl1-mesa-dri. If your last command doesn't work, try to install ibgl1-mesa-dri-lts-saucy instead.

share|improve this answer
    
I tried to run : apt-get install libgl1-mesa-dri . And it seems to work for now. Thanks. –  user1529034 Mar 24 at 10:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.