Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently purchased a Lenovo ideapad U430 Touch. I have successfully installed Lubuntu 13.10 with Kernel 3.11.0-18-generic.

Everything has been relatively painless. I've installed tlp for better power management and recently I have noticed that my batter is no longer charging. Using upower -i I get the same percentage (currently 8%) and the energy-rate is 0 W, even though it says it's charging.

native-path:          BAT1
vendor:               SMP
model:                L12M4P62
power supply:         yes
updated:              Sun 23 Mar 2014 10:05:27 PM PDT (2 seconds ago)
has history:          yes
has statistics:       yes
battery
  present:             yes
  rechargeable:        yes
  state:               charging
  energy:              4.43 Wh
  energy-empty:        0 Wh
  energy-full:         51.72 Wh
  energy-full-design:  52.54 Wh
  energy-rate:         0 W
  voltage:             7.044 V
  percentage:          8%
  capacity:            98.4393%
  technology:          lithium-ion

When I run tlp-stat with the power chord plugged in I see (among other things)

+++ System Status
TLP power save = enabled
power source   = ac

and a little further down

+++ ThinkPad Extended Battery Functions
tp-smapi   = inactive (kernel module 'tp_smapi' not installed)
tpacpi-bat = inactive (kernel module 'acpi_call' not installed)

+++ Battery Status
/sys/class/power_supply/BAT1/manufacturer                   = SMP
/sys/class/power_supply/BAT1/model_name                     = L12M4P62
/sys/class/power_supply/BAT1/cycle_count                    = (not supported)
/sys/class/power_supply/BAT1/energy_full_design             =  52540 [mWh]
/sys/class/power_supply/BAT1/energy_full                    =  51720 [mWh]
/sys/class/power_supply/BAT1/energy_now                     =   4430 [mWh]
/sys/class/power_supply/BAT1/power_now                      =      0 [mW]
/sys/class/power_supply/BAT1/status                         = Unknown

Now initially I installed tp-smapi-dkms and acpi-call-tools, but subsequently purged them since this is not a true ThinkPad.

Things were working fine for the past couple of days after the purge, but now there is no change in the percentage. This has been the case for the past few hours. The fact that the /sys/class/power_supply/BAT1/power_now is 0 [mW] and /sys/class/power_supply/BAT1/status is Unknown from tlp is making me wonder.

One last thing. I have tried, at various times, using LXDE's power manager, which I believe is just the XFCE4 power manager GUI and actually uses upower on the backend, but I'm not 100% sure that is the only thing it uses. Either way it reports the same 8%. Most recently, I came across something on an Arch wiki here that suggested not installing any other power-management tools in addition to tlp, and that cpupower may even break p-state on the CPU.

My questions are:
Does the LXDE power-management use cpupower and did I break something by running it while tlp was active?
Does anyone have any ideas as to why I am seeing the same 8% reported from upower?
Should I install acpi_call?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.