Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used to run Ubuntu 10.10 on my desktop computer, and I had all sorts of settings configured as I liked.

I had to do a fresh install of Ubuntu 11.04, so I lost those settings, but it doesn't seem to matter, because, from what I understand, Emerald support is now either non-existant or shaky, the new version of Compiz is incompatible with previous settings, and Ubuntu is putting its efforts into Unity, not Gnome.

Anyway, the point is, I would like to get back to something like what I had before: Compiz, Emerald, and Gnome.

I'm running Ubuntu "Classic", so I have Gnome. I've got Compiz running, though it seems to crash after every adjustment to the settings.

But I don't have window frames. If I select Metacity as the window manager, most Compiz effects don't work. If I select Emerald, I simply get nothing. In my Emerald themes settings, there are no more themes anymore, and I can't find them in Synaptic.

So... what's the deal with Emerald? Is there something to replace it?

Is this a problem that can be solved without having to build anything from source?

share|improve this question
    
You already have Compiz, 0.9, a complete rewrite form the previous 0.8, so yeah..it's different.There's a PPa that has emerald for natty, and Unity is on top of GNOME 2.32 –  Uri Herrera May 19 '11 at 7:19

2 Answers 2

up vote 6 down vote accepted

To use emerald on 11.04:

Remove Emerald:

$ sudo apt-get purge emerald

Deps:

$ sudo apt-get install libwnck-dev libwnck1.0-cil-dev git automake libtool intltool libdecoration0 libdecoration0-dev

Compile:

git clone git://anongit.compiz.org/fusion/decorators/emerald
cd emerald
git checkout -b compiz++ origin/compiz++
./autogen.sh
./configure --prefix=/usr/local
make && sudo make install

Now, open CompizConfig and enable "Window Decoration", "Resize Window" and "Move Window". Make sure "Window Decoration"'s command is emerald --replace .

Press alt+f2 to run this command:

emerald --replace

You should now have your emerald theme activated and have the ability to move the windows around. :D

11.10 Edits

You may have to modify the directions above slightly:

Compile:

git clone git://anongit.compiz.org/fusion/decorators/emerald
cd emerald
git checkout -b compiz++ origin/compiz++
git reset --hard 0936b42efbc4247d1af16d5043f9a7a36ed8063a
./autogen.sh
./configure --prefix=/usr/local
make && sudo make install

Note: The git reset command goes to a specific release of their code. It seems the latest version is broken, but this is subject to change. You may want to attempt the original instructions, and revert back to commit 0936b42efbc4247d1af16d5043f9a7a36ed8063a only if you are unable to compile Emerald.

share|improve this answer
1  
This helped me going from 10.04->11.10, as well. –  earthmeLon Oct 18 '11 at 23:59

I'm not really sure how well the Emerald in this PPA works as i don't use 11.04, If your Compiz crashes so much, you should reprt it as a bug.

As for replacing Metacity with Emerald you first have to Enable window decorations in CCSM, then set the command to:

     emerald --replace

And you cand download the themes at gnome-look.org or at deviantART.com.

share|improve this answer
    
Thanks for the suggestions. I downloaded the Emerald PPA, enabled window decorations in the CCSM... I'm a little unsure what you mean by "set the commant to", but I opened a terminal and typed that in. It responded with "Gtk-Message: Failed to load module "rgba"" –  Questioner May 19 '11 at 11:14
1  
In the Window decorations settings there a box that says "command" there you type emerald --replace –  Uri Herrera May 19 '11 at 21:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.